Python error running ./mach mochitest -f plain extensions/cookie/test

RESOLVED DUPLICATE of bug 1294099

Status

Testing
Mochitest
RESOLVED DUPLICATE of bug 1294099
a year ago
a year ago

People

(Reporter: jdm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>$ ./mach mochitest -f plain extensions/cookie/test/
>
>######
>### Now running mochitest-plain.
>######
>
>Error running mach:
>
>    ['mochitest', '-f', 'plain', 'extensions/cookie/test/']
>
>The error occurred in code that was called by the mach command. This is either
>a bug in the called code itself or in the way that mach is calling it.
>
>You should consider filing a bug for this issue.
>
>If filing a bug, please include the full output of mach, including this error
>message.
>
>The details of the failure are as follows:
>
>AttributeError: 'Namespace' object has no attribute 'flavor'
>
>  File "/Users/jdm/src/mozilla-central/testing/mochitest/mach_commands.py", line 501, in run_mochitest_general
>    **harness_args)
>  File "/Users/jdm/src/mozilla-central/testing/mochitest/mach_commands.py", line 247, in run_desktop_test
>    result = mochitest.run_test_harness(parser, options)
>  File "/Users/jdm/src/mozilla-central/obj-x86_64-apple-darwin13.4.0/_tests/testing/mochitest/runtests.py", line 2676, in run_test_harness
>    if options.flavor in ('plain', 'browser', 'chrome'):

I can't figure out how to run these tests locally; removing `-f plain` hits the same error, it just takes longer to get to the mochitest-plain suite.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1294099
You need to log in before you can comment on or make changes to this bug.