Closed Bug 1294234 Opened 5 years ago Closed 5 years ago

Run legacy tests with run-task

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla51

People

(Reporter: gps, Assigned: gps)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

As part of running WPT from source checkout (bug 1286900), we'll need to port the TC tasks to use `run-task` so it can do the source checkout.
Comment on attachment 8779871 [details]
Bug 1294234 - Assign command at end of function;

https://reviewboard.mozilla.org/r/70780/#review68326
Attachment #8779871 - Flags: review?(dustin) → review+
Comment on attachment 8779872 [details]
Bug 1294234 - Use run-task for test tasks;

https://reviewboard.mozilla.org/r/70782/#review68328

::: taskcluster/taskgraph/transforms/tests/make_task_description.py:201
(Diff revision 1)
> +    # assemble the bash script in a list that will be joined by spaces.
> +    # Task references are allowed.
> +    args = [
> +        'mkdir -p /home/worker/workspace &&',
> +        'cd /home/worker/workspace &&',
> +        '/home/worker/bin/test-linux.sh',

Why not make test-linux.sh create and cd into this directory?  I think that would save you having to use `bash -cx` in the command, which would save you the need to shell-quote everything.

::: taskcluster/taskgraph/transforms/tests/make_task_description.py:236
(Diff revision 1)
>  
> -    worker['command'] = command
> +    worker['command'] = [
> +        '/home/worker/bin/run-task',
> +        '--',
> +        'bash', '-cx',
> +        # Allow variable substitution.

`# allow task references`
Comment on attachment 8779870 [details]
Bug 1294234 - Add test-ubuntu*.sh scripts to Docker image;

https://reviewboard.mozilla.org/r/70778/#review68330
Attachment #8779870 - Flags: review?(dustin) → review+
Comment on attachment 8779872 [details]
Bug 1294234 - Use run-task for test tasks;

https://reviewboard.mozilla.org/r/70782/#review68396

::: taskcluster/taskgraph/transforms/tests/make_task_description.py:198
(Diff revision 2)
>  
>      # assemble the command line
> +    command = [
> +        '/home/worker/bin/run-task',
> +        '--',
> +        '/home/worker/bin/test.sh',

so clean!

(assuming it works)
Attachment #8779872 - Flags: review?(dustin) → review+
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/710d37b610a8
Add test-ubuntu*.sh scripts to Docker image; r=dustin
https://hg.mozilla.org/integration/autoland/rev/3cfc4041d48d
Assign command at end of function; r=dustin
https://hg.mozilla.org/integration/autoland/rev/d118ab526ad8
Use run-task for test tasks; r=dustin
This needs the first commit from bug 1294109.

I'll reland this tomorrow once the trees are happier.
Duplicate of this bug: 1292730
Pushed by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a536501b52e2
Use more byte literals; r=ekyle
https://hg.mozilla.org/integration/autoland/rev/527ab73d66dc
Add test-ubuntu*.sh scripts to Docker image; r=dustin
https://hg.mozilla.org/integration/autoland/rev/c72df0f64a7f
Assign command at end of function; r=dustin
https://hg.mozilla.org/integration/autoland/rev/25bc6ca8f19f
Use run-task for test tasks; r=dustin
Flags: needinfo?(gps)
Backout by gszorc@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b17f42ecbc3c
Backed out changeset 25bc6ca8f19f for breaking TC tests
Comment on attachment 8780637 [details]
Bug 1294234 - Use more byte literals;

This was reviewed in another bug.
Attachment #8780637 - Flags: review?(klahnakoski) → review+
Blocks: 1295380
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.