Live bookmark failed to load

RESOLVED INVALID

Status

()

Firefox
RSS Discovery and Preview
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Konstantin Svist, Unassigned, NeedInfo)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160729072959

Steps to reproduce:

* Install NoScript extension
* Disable scripts on http://feeds.feedburner.com/ (or all)
* Add a Live Bookmark for any feed under http://feeds.feedburner.com/*, e.g. https://feeds.feedburner.com/TEDTalks



Actual results:

Live bookmark fails to load.
User sees a reload option, but clicking it doesn't seem to do anything.
There's no obvious notice that scripts should be enabled


Expected results:

Live bookmark should load even with scripts disabled. There should be no scripts executed on fetching/displaying an RSS feed..

Even if something is being denied, user should be shown a notice of the reason why it's not working.

Note: this is new behavior that started in 48 branch -- Live Bookmarks loaded fine before

Updated

a year ago
Component: Untriaged → RSS Discovery and Preview

Comment 1

a year ago
I installed the add-on NS (so by default, all JS is disabled) and subscribed this feed (http://feeds.feedburner.com/tedtalks_audio). I opened the feed directory and all feeds loaded.

Did you test with a clean profile and only NS?
Flags: needinfo?(fry.kun)
(Reporter)

Comment 2

a year ago
Looks like you're right -- it doesn't show up in a fresh profile with just NS..
But it's broken in my regularly-used profile until I unblock the site in NS -- so weird!
looks like due to add-ons, not a firefox bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.