import/src/nsImportService.cpp: ignoring return value of "nsresult NS_NewISupportsArray(nsISupportsArray**)

RESOLVED DUPLICATE of bug 1294260

Status

MailNews Core
Build Config
RESOLVED DUPLICATE of bug 1294260
a year ago
a year ago

People

(Reporter: ewong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
getting this bustage:

ranlib: /lib64/libz.so.1: no version information available (required by ranlib)
/builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.5/../../../../x86_64-unknown-linux-gnu/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.5/../../../../x86_64-unknown-linux-gnu/bin/as)
/usr/bin/ccache /builds/slave/c-cen-t-lnx/build/gcc/bin/gcc -m32 -march=pentiumpro -std=gnu99 -o pralarm.o -c -I/builds/slave/c-cen-t-lnx/build/objdir/dist/system_wrappers -include /builds/slave/c-cen-t-lnx/build/mozilla/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -D_NSPR_BUILD_ -DHAVE_FCNTL_FILE_LOCKING -D_GNU_SOURCE -DLINUX -Di386 -D_PR_PTHREADS -I/builds/slave/c-cen-t-lnx/build/mozilla/config/external/nspr/pr -I/builds/slave/c-cen-t-lnx/build/objdir/config/external/nspr/pr -I/builds/slave/c-cen-t-lnx/build/mozilla/config/external/nspr -I/builds/slave/c-cen-t-lnx/build/mozilla/nsprpub/pr/include -I/builds/slave/c-cen-t-lnx/build/mozilla/nsprpub/pr/include/private -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include  -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nspr -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nss       -fPIC  -include /builds/slave/c-cen-t-lnx/build/objdir/mozilla-config.h -DMOZILLA_CLIENT -MD -MP -MF .deps/pralarm.o.pp  -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -gdwarf-2 -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe  -gdwarf-2 -freorder-blocks -Os -fno-omit-frame-pointer    /builds/slave/c-cen-t-lnx/build/mozilla/nsprpub/pr/src/misc/pralarm.c
/builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.5/../../../../x86_64-unknown-linux-gnu/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.5/../../../../x86_64-unknown-linux-gnu/bin/as)
/usr/bin/ccache /builds/slave/c-cen-t-lnx/build/gcc/bin/gcc -m32 -march=pentiumpro -std=gnu99 -o pratom.o -c -I/builds/slave/c-cen-t-lnx/build/objdir/dist/system_wrappers -include /builds/slave/c-cen-t-lnx/build/mozilla/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -D_NSPR_BUILD_ -DHAVE_FCNTL_FILE_LOCKING -D_GNU_SOURCE -DLINUX -Di386 -D_PR_PTHREADS -I/builds/slave/c-cen-t-lnx/build/mozilla/config/external/nspr/pr -I/builds/slave/c-cen-t-lnx/build/objdir/config/external/nspr/pr -I/builds/slave/c-cen-t-lnx/build/mozilla/config/external/nspr -I/builds/slave/c-cen-t-lnx/build/mozilla/nsprpub/pr/include -I/builds/slave/c-cen-t-lnx/build/mozilla/nsprpub/pr/include/private -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include  -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nspr -I/builds/slave/c-cen-t-lnx/build/objdir/dist/include/nss       -fPIC  -include /builds/slave/c-cen-t-lnx/build/objdir/mozilla-config.h -DMOZILLA_CLIENT -MD -MP -MF .deps/pratom.o.pp  -Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -gdwarf-2 -fno-strict-aliasing -ffunction-sections -fdata-sections -fno-math-errno -pthread -pipe  -gdwarf-2 -freorder-blocks -Os -fno-omit-frame-pointer    /builds/slave/c-cen-t-lnx/build/mozilla/nsprpub/pr/src/misc/pratom.c
/builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.5/../../../../x86_64-unknown-linux-gnu/bin/as: /lib64/libz.so.1: no version information available (required by /builds/slave/c-cen-t-lnx/build/gcc/bin/../lib/gcc/x86_64-unknown-linux-gnu/4.8.5/../../../../x86_64-unknown-linux-gnu/bin/as)
../../../../mailnews/import/src/nsImportService.cpp: In member function 'virtual nsresult nsProxySendRunnable::Run()':
../../../../mailnews/import/src/nsImportService.cpp:333:54: error: ignoring return value of 'nsresult NS_NewISupportsArray(nsISupportsArray**)', declared with attribute warn_unused_result [-Werror=unused-result]
   NS_NewISupportsArray(getter_AddRefs(supportsArray));
                                                      ^
cc1plus: all warnings being treated as errors
make[4]: *** [nsImportService.o] Error 1
make[4]: Leaving directory `/builds/slave/c-cen-t-lnx/build/objdir/mailnews/import/src'
make[3]: *** [mailnews/import/src/target] Error 2
make[3]: *** Waiting for unfinished jobs....
(Reporter)

Comment 1

a year ago
I'm guessing this is going to be fixed by the dependent bug.
Depends on: 1272893

Comment 2

a year ago
There is a patch already in bug 1294260...
But yes, if bug 1272893 had been fixed, this wouldn't happen.

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1294260
You need to log in before you can comment on or make changes to this bug.