Download panel drag-drop broken in Firefox 48.0 on Ubuntu 14.04

RESOLVED DUPLICATE of bug 1287823

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 1287823
2 years ago
2 years ago

People

(Reporter: sxc731, Unassigned)

Tracking

48 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728204513

Steps to reproduce:

0. Ubuntu 14.04 LTS desktop with Firefox 48.0
1. Download a document by clicking on a button (described behaviour was reproduced with a PDF and a '.epub' ebook) 
2. Click on "Save File" in the Firefox download dialog.
3. The download proceeds successfully.  
4. I now want to move the download to a separate location on the filesystem by clicking on the download arrow in the toolbar and drag-dropping the file into my home directory using the OS file manager (Ubuntu's "Files" application which, I understand, is a rebrand of Gnome's Nautilus).


Actual results:

Instead of my file being moved or copied to the target location, I get a weird text file, titled: "file:---home-<myUserName>-Downloads-<downloadFileName>..txt".  The content of the text file is "file:///home/<myUserName>/Downloads/<downloadFileName.epub>"



Expected results:

In Firefox 47.0 and previous version, the downloaded file gets copied or moved (not sure which, doesn't really matter) verbatim to the chosen target location.  This is therefore a regression in Firefox 48.0
(Reporter)

Updated

2 years ago
Has Regression Range: --- → yes
Component: Untriaged → Downloads Panel
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

2 years ago
Thanks for reporting! It seems that a similar issue is being discussed in bug 1287823.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1287823
You need to log in before you can comment on or make changes to this bug.