element.animate(..) freezes the translate property at the end (Web animations)

RESOLVED INVALID

Status

()

Core
DOM: Animation
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: cyril.auburtin, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160802030437

Steps to reproduce:

https://jsfiddle.net/9ot7w02g/12/


Actual results:

When clicking play, if the animation started on an icon it should end one icon below.

It doesn't work: it finishes at the same icon the first time, then it seems to work, but it's not possible to modify foo.style.transform from devtools as shown in http://i.imgur.com/CRj76bz.gif

Updated

2 years ago
QA Whiteboard: [bugday-20160815]
Component: Untriaged → DOM: Animation
Product: Firefox → Core
(Reporter)

Comment 1

2 years ago
note: it does more or less the same freezing on chrome (canary). I don't understand if it's by spec, it would be strange though. It's just impossible to change the transform inline style after the .animate ends
Though I might not understand what the problem is, removing fill:'forwards' might solve the problem.
(Reporter)

Comment 3

2 years ago
Oh indeed, well caught, it's a bit hard to understand those different options, I'll learn more

thanks
Thank you for quick reply.  Then I am going to close this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.