Closed Bug 1294602 Opened 4 years ago Closed 3 years ago

mlb.tv plays in 32-bit, fails with Media Error in 64-bit

Categories

(Core :: Plug-ins, defect, P2)

48 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: jjreisert, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

Watch baseball game using mlb.tv account.


Actual results:

Using 64-bit Firefox, the real-time video stream tries to load, but eventually gets a Media Error.


Expected results:

Using 32-bit Firefox, the stream starts right up.
Hi Jim, 
I cannot reproduce this as I do not have a mlb account. Also the NASA stream is fine for me. Can you provide links to any other sites that may be problematic for you? 
Version 	48.0
Build ID 	20160726073904
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Component: Untriaged → Audio/Video: MediaStreamGraph
Product: Firefox → Core
What is the URL for the NASA stream?  I can try it at home.

If you contact me via direct E-mail, I'll give you my MLB login credentials so you can test it.
Hi Jim,
This is the NASA link I applied to stream live NASA TV
http://www.nasa.gov/multimedia/nasatv/index.html#public
Does the NASA TV site use Flash?  MLB.tv uses Flash, not HTML5 or anything else I can tell.
Yes, the NASA TV requires Flash. My version is 22.0.0.209; pls let me know if you have a different version. Thanks
-> Plugins, since this is Flash.

http://mlb.mlb.com/mlb/help/faq_nexdef.jsp
"First, disable any Ad Blocking features or plug-ins that you may have enabled in your browser or security programs. If you are using Firefox, disable the following plug-ins if you are using them: AdBlock Plus, FlashBlock, and NoScript."

Also check HW acceleration in flash: https://support.mozilla.org/en-US/questions/999604

mlb.tv is apparently a bit of a resource hog, and somewhat fragile (reddit threads), but we should try to figure out if it's anything on Firefox's side
Component: Audio/Video: MediaStreamGraph → Plug-ins
Could you please try installing the Flash beta to see if this fixes the problem? We've been working on a new graphics rendering system with Adobe that should make some problems like this much better: http://labs.adobe.com/technologies/flashruntimes/flashplayer/

Let me know: if the beta does help, Adobe will probably roll it out in the September release. If not, there may not be much we can do about it.
Flags: needinfo?(jjreisert)
Yes, Adobe Flash 23 Beta and Firefox 48.0.1 work just fine together.  MLB is back! Thanks.

For the record, whereas Firefox 48.0 and Adobe Flash 22 resulted in "Media Error", Firefox 48.0.1 and Adobe Flash 22 just gave me a blank Flash window w/o the media error.
Firefox 48.0.2 seems to have broken things again.
Is it worth trying Firefox 49 beta?
There were no relevant changes between FF48.0.1 and 48.0.2. You're welcome to try other builds, but this is quite strange.
This version of 64-bit Firefox seems to work with MLB.tv on 64-bit Windows 10:

Version:   49.0
Build ID:  20160907153016
Flash:     23.0.0.151 (NPSWF64_23_0_0_151.dll)

I exited/started Firefox a couple of times to be sure.
After watching Boston/Toronto game on MLB.tv for 1.5 hours, it went to a commercial break and never came back.  I refreshed the browser, and got a Media Error.  I re-started the browser, again got a Media Error.  Something isn't right!
Jim, possibly another RTMPS/ssl issue that's been buried? I suspect we should at least add this to the test matrix.
Flags: needinfo?(jjreisert) → needinfo?(jmathies)
->cpeterson to hook up with 64-bit rollout/tracking/testing bugs
Flags: needinfo?(cpeterson)
Priority: -- → P2
The MLB.tv demo videos [1] work for me in 64-bit Nightly 55 both with and without Flash. Maybe the live streams are still a problem, but I can't test without an MLB.tv account.

[1] http://m.mlb.com/video/v1254719483
Flags: needinfo?(cpeterson)
Chris, contact me via E-mail (off-line) and I'll give you access to my MLB.tv account.  They still insist on Flash, does not support HTML5.
Thanks, Jim. This bug might be a duplicate of Xfinity video bug 1334803. Once that bug is fixed, then we should retest this bug.
Depends on: 1334803
Flags: needinfo?(jmathies)
How can I test this myself - i.e. what build do I need?  I'm currently on 54.0.1
Thanks - Jim
(In reply to Jim Reisert from comment #19)
> How can I test this myself - i.e. what build do I need?  I'm currently on
> 54.0.1
> Thanks - Jim

If you don't mind, please test a 64-bit builkd of Windows Nightly - 

https://www.mozilla.org/en-US/firefox/nightly/all/

This bug should be fixed in these builds.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jjreisert)
Running:  56.0a1 (2017-07-15) (64-bit)

It's working fantastic - thanks!  I also tried 56.0 Beta 9, that version still had the problem.
Flags: needinfo?(jjreisert)
Thanks for your testing and patience, Jim! I will resolve this bug as fixed based on your feedback. This was a very tricky compatibility bug in Firefox's Windows sandbox code.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
I'm watching a game and noticed that the memory usage has been growing over time.  It started around 725MB but is now up to 1017MB and growing steadily.  Is this just a general problem with Flash, or something specific to MLB?

I'm running this version:  Firefox 56.0b10 (64-bit)
on Windows 10 64-bit
You need to log in before you can comment on or make changes to this bug.