b2g-installer doesn't pull blobs from Fairphone 2

UNCONFIRMED
Unassigned

Status

Firefox OS
B2gInstaller
UNCONFIRMED
a year ago
a year ago

People

(Reporter: Novski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8780551 [details]
successfull Firefox OS b2g-installer logs .txt

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

i made a B2GOS blobfree build and its available on https://github.com/mozilla-b2g/b2g-installer-builds/releases/download/b2gos-experimental-fp2/FP2.blobfree-dist.zip
I changed the builds.json of b2g-installer.
I conected my FP2 and it got recognized.
I selected my new "B2G OS transition".
clicked flash.
It ran throug the download and all the steps with giving me a successfuly builded statement at the end.
I then analized the "nightly user build" of juan gomez that builds and boots correctly.
I analized the build of my "B2G OS transition" and seen that it doesn't pull the blobs from the device as in the "nightly user build".
So i searched for the reason and found another file with the build number and updated it.


Actual results:

Device didn't boot


Expected results:

Device should boot normal as with the nightly user it does.
(Reporter)

Comment 1

a year ago
Created attachment 8780552 [details]
unsuccessfull B2G b2g-installer logs .txt

Comment 2

a year ago
well it's trying to pull the blobs, but fails:

> adb pull /system/system/lib/hw/gps.default.so /Users/FirefoxNightly/Library/Caches/TemporaryItems/b2g-installer/FP2/blobs/system/system/lib/hw/gps.default.so fail BAD_RESPONSEabout.js:159:9

is anything different with your device?
Flags: needinfo?(i.hoerler)
Can you use the provided VM to make sure this is not because of an external cause? It is possible that Firefox Nightly broke the addon, or that ADB Helper is broken.
Novski, you got tricked by path:
> adb pull /system/system/lib/hw/gps.default.so

There's two /system there :). I remember that Juan had to fight some issues like this, maybe he can help?
Flags: needinfo?(jgomez)
(Reporter)

Comment 5

a year ago
no nothing differnt. I tried with the same build version he made it for: 1.1.7.
(In reply to Novski from comment #5)
> no nothing differnt. I tried with the same build version he made it for:
> 1.1.7.

Speaking of this, I had a look at your PR, and I really think we should only support the latest upstream release. They might contain very important fixes, so it's better to ask the user to have something uptodate.

Concerning the adb pull, you should be able to fix the path by modifying the content of the zip file, in the list of blobs. But the real fix is to properly generate it :)
(Reporter)

Comment 7

a year ago
What do you think, can i change all lines in 
https://github.com/mozilla-b2g/device-fairphone2/blob/b7d48dc7ff9e8a6e4b167d8d295ecb90a07057f4/proprietary-files.txt
to without "system/" ?
I found this commit from juan https://github.com/atilag/device-fairphone2/commit/b7d48dc7ff9e8a6e4b167d8d295ecb90a07057f4
And im not shure if that change wold also take changes to the normal build of Fairphone2 or only to the blobfree b2g-installer...
Flags: needinfo?(i.hoerler) → needinfo?(lissyx+mozillians)
Well, for a quick hack/test, you can for sure remove the "system/" part, but I really remember we hit the same issue already with Juan and I don't remember the proper explanation. I think this file is being used in normal build process, so you might break it yes. Just make sure you removed all out/ and start with a clean vendor/ and tree in general, it might be possible something is screwing with you there.

Otherwise, sad news, you are going to have to debug my nice shell/makefile targets in gonk-misc/Android.mk that finds the blobs :).

But really, just hack in the generated blobfree distribution to remove the extra "system/", that should at least help you make sure this part is good and verify nothing else is missing.
Flags: needinfo?(lissyx+mozillians)
I have fixed blobfree image build in the device-fairphone2 (github) repository.
You should be able to build it now without problems.
Flags: needinfo?(jgomez)
You need to log in before you can comment on or make changes to this bug.