It's hard to find where to download Firefox Release if you're running Nightly

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
a year ago
9 months ago

People

(Reporter: botond, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [q3 sprint 5])

(Reporter)

Description

a year ago
STR:
  1. Run Firefox Nightly. Assume you don't have Firefox Release installed.
  2. Go to mozilla.org, and follow the links to Firefox and Desktop,
     landing at https://www.mozilla.org/en-US/firefox/desktop/
  3. The page there shows a green checkmark and says "Your Firefox is up
     to date". There's no download link for Firefox Release in sight.

Eventually, by following the links "Need help with anything?" -> "Install and update" -> "Install Firefox on Linux" -> "Firefox download page" (links to http://www.getfirefox.com/) -> "Want a fresh copy?", I was able to find a download link for Firefox Release, but I think this was way more difficult than it should have been.

Suggested resolution:
  If a user visits https://www.mozilla.org/en-US/firefox/desktop/ or
  http://www.getfirefox.com/ and they are on a channel other than
  Release, point this out and offer them a link to download Release
  (and other channels if appropriate).
See Also: → bug 1301391

Updated

a year ago
Whiteboard: [q3 sprint 5]
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308973
Oops sorry, this isn't a duplicate as it relates to a different page (/firefox/new/desktop/). Re-opening, but we'll hopefully be fixing this very shortly too.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This was fixed back in bug 1323707
Status: REOPENED → RESOLVED
Last Resolved: a year ago9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.