Closed Bug 1294929 Opened 5 years ago Closed 5 years ago

Don't hold "No matches" style, after clearing the "No matches" result using inspector-searchinput-clear

Categories

(DevTools :: Inspector, defect, P1)

defect

Tracking

(firefox50 unaffected, firefox51 verified)

VERIFIED FIXED
Firefox 51
Iteration:
51.1 - Aug 15
Tracking Status
firefox50 --- unaffected
firefox51 --- verified

People

(Reporter: magicp.jp, Assigned: gasolin)

References

Details

(Whiteboard: [reserve-html])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160812030200

Steps to reproduce:

1. Start Nightly
2. Go to about:home
3. Open DevTools > Inspector
4. Enter any unmatch word (e.g. zzz) into inspector-searchbox  => Result will be "No matches"
5. Click inspector-searchinput-clear (x) icon
6. Check inspector-searchbox style


Actual results:

Still hold "No matches" style.

Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=c9bbdb627b7804fee47aa6a6708647e6e589d09c&tochange=3269dd1a824d1b42cb021d1fb6858885179940b0


Expected results:

Don't hold "No matches" style, after clearing the "No matches" result using inspector-searchinput-clear
Blocks: 1265759
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → All
Hardware: Unspecified → All
Flags: qe-verify?
Whiteboard: [devtools-html] [triage]
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: qe-verify? → qe-verify+
Priority: -- → P3
QA Contact: cristian.comorasu
Whiteboard: [devtools-html] [triage] → [reserve-html]
Comment on attachment 8780966 [details]
Bug 1294929 - remove no-match class when tap clear button;

https://reviewboard.mozilla.org/r/71480/#review69218

I believe for the commit messages you should be using r=gl. I have been trying to land patches for you since there is only one sheriff for the next 2 weeks and I think I saw it complain about the commit message style the last time.
Attachment #8780966 - Flags: review?(gl) → review+
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/c9d9d817ae30
remove no-match class when tap clear button; r=gl
mozreview doc suggest use `r?reviewer` and the pushbot will change it to `r=reviewer`

http://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview/commits.html#specifying-reviewers-in-commit-messages

If that is the case I'll change to `r=reviewer` format. And maybe we should bring sheriff's feedback to mozreview devs?
(In reply to Fred Lin [:gasolin] from comment #4)
> mozreview doc suggest use `r?reviewer` and the pushbot will change it to
> `r=reviewer`
> 
> http://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview/
> commits.html#specifying-reviewers-in-commit-messages
> 
> If that is the case I'll change to `r=reviewer` format. And maybe we should
> bring sheriff's feedback to mozreview devs?

Seems like ntim already pushed it, but I usually push it manually which is why I ask for the change.
(In reply to Fred Lin [:gasolin] from comment #4)
> mozreview doc suggest use `r?reviewer` and the pushbot will change it to
> `r=reviewer`
> 
> http://mozilla-version-control-tools.readthedocs.io/en/latest/mozreview/
> commits.html#specifying-reviewers-in-commit-messages
> 
> If that is the case I'll change to `r=reviewer` format. And maybe we should
> bring sheriff's feedback to mozreview devs?

While mozreview actually changes r? to r= after pushing to autoland, it's more convenient for whoever pushes to use r=. r= is also supported by mozreview, so I would recommend using it.

Providing feedback to mozreview devs would be a good thing.
https://hg.mozilla.org/mozilla-central/rev/c9d9d817ae30
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Iteration: --- → 51.1 - Aug 15
Priority: P3 → P1
I reproduced this bug using Fx 51.0a1, build ID:  20160812030200, on Windows 10 x64.
I can confirm the bug is fixed, I verified using Fx 51.0a1 build ID: 20160817030202 , on Windows 10 x64, Ubuntu 14.04 LTS and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
I have reproduced this bug with Nightly 51.0a1(2016-08-13) on Elementary OS 64bit. 

In latest Nightly 51.0a1(2016-08-17), clearing search by clicking (x) clears the search and returns the search box to normal state but the text "No matches" still remains. It is also true when the search returns some result(i.e shows "1 of 1" this type of text). 

Nightly 51.0a1
build id 	20160817030202
user agent	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160817]
Thanks for report Sayad! 
What you seen will be resolved at bug 1295390
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.