Open a local .swf file on Linux leading to choose to save the file, instead of open the file with flash plugin

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: piotr5, Unassigned)

Tracking

({qawanted})

45 Branch
x86_64
Linux
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160809144357

Steps to reproduce:

opening a local .swf file in firefox (on linux) by pressing F10, selecting File, and selecting File Open in the menu, and choosing some flash file


Actual results:

results in the suggestion to "download" it. when I alter /usr/share/mime/packages/freedesktop.org.xml according to http://askubuntu.com/questions/7240/how-do-i-play-swf-files (i.e. switch <mime-type type="application/vnd.adobe.flash.movie"> with the alias application/x-shockwave-flash and then run "sudo update-mime-database /usr/share/mime"):


Expected results:

the file plays normally as if being part of a webpage on the net. so it seems firefox only tries to open the filetype based on the official name for the mime-type and doesn't try opening as a filetype of the various aliases first...

Updated

2 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → File Handling
Ever confirmed: true
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Summary: in menu file>open does check the main mime types but not their aliases for ability to play → Open a local .swf file on Linux leading to choose to save the file, instead of open the file with flash plugin

Comment 1

2 years ago
Hi, Piotr,

I'm not sure which operating system you're using.
But, I would like to suggest you to install adobe flash plugin.
If you're using Ubuntu, please install it on Ubuntu Software Center (Attach the screenshot).

Thank you!
Flags: needinfo?(piotr5)

Comment 2

2 years ago
Created attachment 8781011 [details]
ADOBE_FLASH_PLUGIN.png
(Reporter)

Comment 3

2 years ago
my os is gentoo, and I do have www-plugins/adobe-flash-11.2.202.632 installed. but it doesn't work unless I change /usr/share/mime/packages/freedesktop.org.xml and rerun "update-mime-database /usr/share/mime" as root. maybe the bug is in adobe-flash? do new versions of it have the bug fixed? or maybe versions of firefox newer than my www-client/firefox-45.3.0 have that bug already fixed? of course displaying web-content containing flash-scripts is without problems, afterall websites do specify explicitely the mime-type.

since you asked, dear William Hsu, I'm assuming you have no such problems? what does your /usr/share/mime/packages/freedesktop.org.xml say? which is the mime main-type and which is the alias? maybe your os already has altered that file? truth is, when I try to open swf-files firefox suggests to download them or start them in winebrowser -- till I made the change the folks on ubuntu suggested. but I guess that's just the way my os is configured...

nonetheless, if my suspicion is correct, firefox does ignore aliases. and this is a bug in firefox!

Comment 4

2 years ago
It seems to me that your OS causes the problem.

Here is my system configuration which pulls from a pure VM.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
  <mime-type type="application/vnd.adobe.flash.movie">
    <comment>Shockwave Flash file</comment>
    <comment xml:lang="ar">ﻢﻠﻓ Shockwave Flash</comment>
    <comment xml:lang="ast">ficheru Shockwave Flash</comment>
    <comment xml:lang="be">Fajł Shockwave Flash</comment>
    ...
    <alias type="application/x-shockwave-flash"/>
    <alias type="application/futuresplash"/>
    <generic-icon name="video-x-generic"/>
    <magic priority="50">
      <match value="FWS" type="string" offset="0"/>
      <match value="CWS" type="string" offset="0"/>
    </magic>
    <glob pattern="*.swf"/>
    <glob pattern="*.spl"/>
  </mime-type>
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Thank you!

Comment 5

2 years ago
(In reply to Piotr Sawuk from comment #3)

> since you asked, dear William Hsu, I'm assuming you have no such problems?

Yes, I can play a *.swf file on Firefox 48 after I install adobe flash plugin.
(Reporter)

Comment 6

2 years ago
I see. guess something went wrong in installing flash -- it got associated to the wrong mime type. clicking on add-ons>plugins and then following the "more" link I see the registered mime-types for flash are only
application/x-shockwave-flash (Shockwave Flash: swf),
application/futuresplash (FutureSplash Player: spl)
/usr/lib64/nsbrowser/plugins/libflashplayer.so too mentions just the two of them. i.e:

$ strings /usr/lib*/nsbrowser/plugins/libflashplayer.so |grep futuresplash:spl
application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player (x3)
$ cksum /usr/lib??/nsbrowser/plugins/libflashplayer.so
1916099323 17540708 /usr/lib32/nsbrowser/plugins/libflashplayer.so
1667934888 19331392 /usr/lib64/nsbrowser/plugins/libflashplayer.so

and naturally the source-packages have the same checksum for this file. do you get anything different? or do you have a different version? in mine application/vnd.adobe.flash.movie simply is mentioned nowhere! if you have the same, maybe the bug already has been fixed in your version of firefox? (in gentoo your version firefox-48.0 is marked unstable/untested.)

Comment 7

2 years ago
Hi, Piotr,

Good day.
I'm not familiar with adobe-plugin. But, I would like to suggest you to check your Firefox preferences, and see if the flash plugin is associated with Firefox.
@ URL BAR => about:preferences#applications
Attach the screenshot (FIREFOX_PREFERENCE.png)

By the way, I installed Firefox 45 on my VM. The Abobe flash plugin works as normal.
Here are the information you may interest.

whsu@ubuntu:~$ strings /usr/lib/flashplugin-installer/libflashplayer.so | grep futuresplash:spl
application/x-shockwave-flash:swf:Shockwave Flash;application/futuresplash:spl:FutureSplash Player

whsu@ubuntu:~$ cksum /usr/lib/flashplugin-installer/libflashplayer.so 
1667934888 19331392 /usr/lib/flashplugin-installer/libflashplayer.so

Thanks!

Comment 8

2 years ago
Created attachment 8782267 [details]
FIREFOX_PREFERENCE.png

Comment 9

2 years ago
Hi, Piotr,

Good day!
Are you still able to reproduce this problem on your build or the latest Firefox build?
Flags: needinfo?(piotr5)

Comment 10

2 years ago
Please help verify this bug to see if you still can reproduced it on the latest release build.
Thank you.
Flags: needinfo?(piotr5)
Keywords: qawanted

Updated

2 years ago
Priority: -- → P3

Comment 11

a year ago
This is still valid, here is the same problem also in Chrome/Chromium:
https://bugs.chromium.org/p/chromium/issues/detail?id=380347

Comment 12

a year ago
To reproduce, you need any Linux system running a new shared-mime-info-1.8 version, for example, due to this commit:
https://cgit.freedesktop.org/xdg/shared-mime-info/commit/?id=2d385ff07eae60f9d92bf932ed7e95fa94dc276d

Comment 13

a year ago
Last good build: Nightly - 18.0a1 2012-09-27
First bad build: Nightly - 18.0a1 2012-09-28
I manually generated a pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b038e9e2023f&tochange=895f66c4eada

I tested first on released versions and then I moved to the Nightly versions using Ubuntu 16.04. This bug seems to trace back to 2012. 

I would like to mention that on the latest Nightly nothing happens. The browser doesn't play the file nor does it try to save it to my PC. I am not sure why that is happening.

Also, considering that this is such an old regression, what is the expected result now? Because when I am trying to reproduce the same steps in Chrome, the browser tries to save the file on my computer. My guess is that maybe the browsers are not compatible with this type of files anymore.
Flags: needinfo?(paolo.mozmail)

Comment 14

a year ago
Thanks for bringing this back to attention. I believe we have intentionally removed the ability to open local SWF files in Firefox some time ago, so this old regression is not relevant anymore.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(paolo.mozmail)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.