If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Data failing to save on quit with clear data on exit.

RESOLVED DUPLICATE of bug 1266594

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1266594
a year ago
11 months ago

People

(Reporter: Steve, Unassigned)

Tracking

({mobile})

49 Branch
ARM
Android
mobile
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

1. Clear app-data.
2. Install the following add-ons:

https://addons.mozilla.org/en-US/firefox/addon/userunified-script-injector/
https://addons.mozilla.org/en-US/firefox/addon/speed-tweaks-speedyfox/
https://addons.mozilla.org/en-US/android/addon/tap-translate/
https://addons.mozilla.org/en-US/android/addon/html5-video-everywhere/?src=ss
https://noscript.net/nsa/latest


3. Create a few scripts with the USI add-on or change some settings with other add-ons.
4. Enable Clear private data on exit (Settings > Privacy > Clear private data on exit > check all > OK).
5. Quit Firefox (Menu > Quit)

If you can't cause it to happen right away, play around with it a bit.


Actual results:

Quiting Firefox will result in data loss, add-on data won't save and recently removed add-ons/themes come back.


Expected results:

Add-on data should be saved along with anything else that needs to be saved. I spent a good hour playing around with this both using the standard version of Firefox along with the beta version, both seem to have this issue.
(Reporter)

Comment 1

a year ago
At first, I thought this may have been an add-on specific issue, but after having Firefox restore some add-ons and themes that I removed after I quit, I believe it may be a browser issue that may have something to do with having multiple add-ons.

I'm using a Galaxy Note 3 on Android 5.0 using the latest version of Firefox for Android (v. 48).
Keywords: mobile
OS: Unspecified → Android
Hardware: Unspecified → ARM
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1266594
(Reporter)

Updated

11 months ago
Version: 48 Branch → 49 Branch
(Reporter)

Comment 3

11 months ago
Not a duplicate, still an issue in version 49.0.2 of Firefox for Android.
You need to log in before you can comment on or make changes to this bug.