Closed Bug 1294968 Opened 3 years ago Closed 3 years ago

[e10s] Increased CPU use during startup

Categories

(Toolkit :: Startup and Profile System, defect)

x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1295214

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Details

Attachments

(1 file)

Attached image startup cpu time.png
Currently: During session restore the both parent and child process are using 1 core each. The child process does not grow in footprint during that time, so presumably no content is loaded yet at that point.

Previously: Only the parent process would burn CPU time while creating (lazy-loaded) tabs
On the French community board, I read a post about the same issue with e10s enabled (very partially) in FF48.
https://forums.mozfr.org/viewtopic.php?p=825036#p825036
Blocks: e10s
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Note that i observed this behavior changing between nightly versions somewhere in the last few weeks and e10s was always enabled. So I doubt it's related to the 48 release.

I have lots of lazy background tabs, so I suspect they somehow trigger work on the child process despite being loaded in the parent process during session restore.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292521
This might not be a good match from your description, if you're still seeing it please reopen.
current nightly does not exhibit that behavior anymore.
You need to log in before you can comment on or make changes to this bug.