Thunderbird freezes for 1 min+ and high svchost.exe CPU after receiving email on Windows 10 when Windows Integrated Search is enabled

VERIFIED INVALID

Status

defect
--
major
VERIFIED INVALID
3 years ago
3 years ago

People

(Reporter: steevithak, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36

Steps to reproduce:

1. Start Thunderbird
2. Click "get messages"
3. Wait for POP3 or IMAP mail to arrive in inbox
4. Attempt to move or delete any email in inbox



Actual results:

Thunderbird freezes for one minute or longer. This happens 100% of the time after the first "get messages" use after starting Thunderbird. It also happens sometimes when successive inbound mail is retrieved but not always. The problem never occurred prior to the upgrade to Windows 10.


Expected results:

Thunderbird should functional normally (not freeze) when moving or deleting newly arrive mail.
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Start *Windows'* safe mode with networking enabled
- win10 https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode
Still In Windows safe mode, start thunderbird in safe mode
- https://support.mozilla.org/kb/safe-mode-thunderbird

Does problem go away?
Severity: normal → major
Keywords: perf
With Windows 10 and Thunderbird running in safe mode the problem does not occur. After going back to Windows regular (unsafe?) mode, the problem returned.
Working in safe mode indicates the problem is not Thunderbird, but rather some software like antivirus or firewall.
Which ones do you run?
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Whiteboard: [antivirus: ??]
No, nothing that's not part of Windows 10. No third party antivirus or firewall programs are in use on the computer. Is it possible Windows 10 itself includes some kind of firewall or antivirus features that need to be disabled? How could I diagnose that? (sorry if that's dumb question, I'm a GNU/Linux user and don't even use Windows 10, I'm helping someone else with this problem). It's pretty much a straight-out-the-box Windows 10 with Thunderbird, Libre Office, and Photoshop. Not much else installed that I can find.
Many possibilities are listed at https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems
What's helped by (i.e. disabled by) safe mode can also be things that are delivered with WIndows 10. 
Please let us know what you find.
I have got one additional clue. When Thunderbird freezes, the Windows Task Manager shows a process called svchost.exe suddenly taking up a lot of CPU time. It seems like once svchost.exe calms down again, Thunderbird unfreezes. Does that help narrow down the problem?
Wow, that's a long list! Ok, I'll try to get that later today and post the results. As a possible shortcut, is there some other open source email program I could recommend to this Windows 10 user that is more Windows friendly? Might be faster to swap her to something that plays nice with Windows 10 without all this debugging.
(In reply to Steevithak from comment #6)
> I have got one additional clue. When Thunderbird freezes, the Windows Task
> Manager shows a process called svchost.exe suddenly taking up a lot of CPU
> time. It seems like once svchost.exe calms down again, Thunderbird
> unfreezes. Does that help narrow down the problem?

WHat you cite doesn't surprise me. I encounter it myself - in fact seen it in the past week which kills my high powered laptop with SSD.

High kernel mode CPU is often seen. (the red line in taskmgr performance tab, you need to turn on kernel display under view)
And/or sometimes these are related to pending, or in progress, Windows updates.

Finding good citations from the vast internet posts can be difficult. A couple decent examples
*  https://answers.microsoft.com/en-us/windows/forum/windows_vista-update/windows-update-hanging-with-high-cpu-for-a-long/f6a36c84-96c8-4511-9998-afe52848f928?auth=1 
* https://superuser.com/questions/1102553/high-cpu-usage-from-nt-kernel-system
Good news everyone! Going through that 24 point diagnostic, I may have stumbled onto the cause. Question 6a (turning off MS-Windows Integrated Search) seemed to eliminate the problem. And there's no apparent side effect that I can see, we tried searching for stuff within Thunderbird and search still seems to work fine, so whatever it did must not be anything obvious. I'm attaching the full results of the diagnostic for whatever they're worth.

Thunderbird freeze diagnosis results
https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems

1. Are you using the newest update of Thunderbird? 
Yes

2. Start Thunderbird in Safe Mode 
Safe vs Normal mode has no effect on the problem. There are no add-ons or extensions installed, this is a stock Thunderbird. 
2a. Is add-on in the list of Problem Extensions?
n/a
2b. Contact the add-on author, and report the problem add-on at SUMO.
n/a

3. If you are running an MS-Windows OS, is Thunderbird better in Windows safe mode with networking enabled?
Yes, this eliminates the problem
3a. you should be running only ONE package, and no more, of each of the following: antivirus, firewall, malware
No third party antivirus, firewall, or malware protection software is installed. Nothing special was done to  Windows 10, so only what's included with Windows 10 default install should be running.
3b. check that you have the newest version of AV/firewall software.
Windows 10 has all available updates, so presumably If windows 10 includes AV or firewall components, they are up to date.
3c. with AV/firewall software turned on, uninstall Thunderbird, DELETE the Thunderbird PROGRAM directory (not data directory), download, reinstall, and retest Thunderbird.
Skipped at user request (she thought this was too risky, even with back ups)
3d. if problem was gone with antivirus software turned off, then see AV performance issues for settings and information which may help.
Skipped - insufficient information to determine if Windows 10 includes an AV component and, if so, how to turn it off.
3e. check with vendor's software support
n/a

4. If you have gmail accounts, is problem seen after unsubscribing the "All Mail" folder?
Unsubscribing had no effect on the problem

5. If you have newsgroup accounts, then... 
n/a (no newsgroup account)

6. Are any of these indexing methods enabled:
6a MS-Windows Integrated Search, Thunderbird setting
****
Yes. After turning this feature off, the problem seems to be solved. 
****
6b. MS-Windows Search try disabling especially if the Thunderbird profile or a Thunderbird account has been moved from the default location
n/a
6c. Google Desktop Search (GDS)? Try uninstalling report from 2010.
n/a
6d. Mac Spotlight Integration
n/a

7. Are you on Windows, and did you move the Thunderbird profile or any Thunderbird account from the default location (%APPDATA%) to a different Windows directory?
Yes, on Wnidows. No, have not relocated any files.

8. If Thunderbird memory usage is more than expected by hundreds of megabytes (MB), then perhaps one or more folders (internally a database) are not being closed, or some other bug.
Unclear. It's using 95.5MB but I have no expectation and question doesn't say how much the questioner expects, so I think this is n/a
8a. Get a diagnostic log of Thunderbird activity with MSGDB:5,timestamp using logging instructions.
n/a
8b. File a bug, then edit the new bug and attach the zipped log file using "Add an attachment".
n/a

9. Does problem resolve by disabling global indexing?
Currently turned on. Since 6a seems to fixed the problem, did not turn off.
9a. Rename global-messages-db.sqlite and restart Thunderbird. global-messages-db.sqlite will rebuild but your system load will be high until all your messages are reindexed.
n/a
9b. Please file a bug about your problem.
n/a

10. Is there an indexing or Search Messages (Ctrl+K) problem, or is global-messages-db.sqlite corrupt?
No, search has always worked fine.

11. Are any folders 2-4GB in size?
No

12. Does disabling interval checks for new mail help? 
No, this had no effect on the problem
12a. Is a low value (1-3 minutes) specified for checking for new mail or draft autosave?
Check every 10 minutes, autosave every 5 minutes
12b. What type of mail account is this (imap or pop), and how many other accounts are the same type?
Both the pop3 and imap accounts exist, both use 10 minute check intervals
12c. Are you absolutely certain that antivirus software is not to blame?
No idea (if I was absolutely certain of the problem cause, I wouldn't be going through these diagnostic checks, lol)

13. Are any non-Inbox IMAP folders configured to check for new messages?
No

14. Do you have thousands of contacts in your address book?
No

15. Is panacea.dat cache file in your profile too big? (>10MB)
No, 268kb

16. If error message indicates a script problem...
No 
16a. Has a proxy ever been defined, and is it working correctly or was the proxy removed?
n/a

17. If using high CPU, check to see if mozilla updater.exe is running in taskmgr
No

18. Is your Thunderbird profile or any part of Thunderbird on a non-local hard drive? If yes, does it preform better when it is moved to the local disk?
No, n/a
18a. USB drive? 
No
18b. network drive?
No
18c. SSD?
No

19. If you suspect slow or high disk activity, on a Windows sytem make sure you have at least 20% free disk space and then do defrag.
75% free space

20. If you have RSS news reader account
n/a (don't use rss news reader)

21. Common resource requirements/maintenance steps:
21a. Do you have the minimum hardware requirements, and enough memory?
Yes
21b. Consider the possibility of hardware problems
Not sure how to answer that, not aware of any hardware problems
21c. Are your folders well maintained, "too large", or perhaps broken:
21c-1. Do you see high memory or long delay when opening a specific folder? Or when moving message to a specific folder?
No, folders open ok. Yes, long delay when manipulating new inbox message in any way.
21c-2. Do any folders lose their sort order or column settings?
No
21c-3. Do you empty trash and junk on a regular basis? You should not be using them for long term storage. Does performance improve if you empty them?
Yes, empty regularly. No,no apparent impact on problem.
21c-4. Do any Inbox or filtered folders have several thousand messages?
No
21c-5. If you are using a version prior to 5, do you regularly (daily or weekly) File > Compact Folders?
n/a, using v45.x

22. If you are running an old version of linux
n/a (running Windows 10)

23. If a bug report in References below matches your problem
n/a

24. If you do not find an existing bug report and still see a problem
n/a
And, by the way, thanks for your help resolving this problem! :)
(In reply to Steevithak from comment #10)
> And, by the way, thanks for your help resolving this problem! :)

You're welcome. And BTW not everyone goes through the whole list, so good for you!

I'm going to leave this as invalid for now - with the idea of opening a new bug report for checking the performance characteristics of Windows Integrated Search.  And perhaps things related to bug 979893 come into play
Status: RESOLVED → VERIFIED
Component: Untriaged → Backend
Product: Thunderbird → MailNews Core
Summary: Thunderbird freezes for 1 min+ after receiving email on Windows 10 → Thunderbird freezes for 1 min+ and high svchost.exe CPU after receiving email on Windows 10 when Windows Integrated Search is enabled
Whiteboard: [antivirus: ??]
Version: 45 Branch → 45
See Also: → 1249056
You need to log in before you can comment on or make changes to this bug.