Crash in js::Debugger::wrapDebuggeeObject after a Proxy is revoked

RESOLVED DUPLICATE of bug 1291011

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 1291011
a year ago
a year ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

(4 keywords)

50 Branch
Unspecified
All
crash, regression, reproducible, testcase
Points:
---

Firefox Tracking Flags

(firefox50-, firefox51 unaffected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8780886 [details]
proxyDebugTest.html

Steps to reproduce:
(1) Open the attached HTML page, and then the Devtools Debugger alongside it.
(2) Place a breakpoint on line 15 of the HTML page.
(3) With the debugger open, click on the button that says "Click here".
(4) You should find yourself stopped on line 15.
(5) Click the "Step in" button in the debugger, trying to go to the next line.

I was able to reproduce the crash in FF50 Aurora from today's code, but not in FF48 as released on Fedora Linux.  I also saw this crash on MacOSX 10, so it's not platform specific.
(Reporter)

Comment 1

a year ago
[Tracking Requested - why for this release]:
It appears to be fixed in today's mozilla-central (FF51) code.  So it might be a simple matter of finding the right patch and uplifting it to aurora.
status-firefox50: --- → affected
status-firefox51: --- → unaffected
tracking-firefox50: --- → ?
OS: Unspecified → All
(Reporter)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291011
No need to track this one, the fix from the other bug 1291011 is approved for uplift to Aurora50.
tracking-firefox50: ? → -
Removing affected per comment 4.
status-firefox50: affected → ---
You need to log in before you can comment on or make changes to this bug.