Web extensions don't display icons in the context menu

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
2 years ago
4 months ago

People

(Reporter: computerwhiz.mozilla, Unassigned)

Tracking

48 Branch

Firefox Tracking Flags

(firefox49 affected, firefox52 verified)

Details

(Reporter)

Description

2 years ago
Why are web extensions not allowed to display icons in the context menu? The MDN says that this ability was added in Firefox 47.0 and that it is just supposed to pull the 16px or 32px file from the manifest, but it doesn't do that.

I've tested in Firefox 48.0 and Firefox 49.0, but neither of them have that ability. I also tested in Firefox 52.0 (Nightly) and it will properly display the context menu icons.

This is only an issue with web extensions, so add-ons using the SDK will still display icons in the context menu. Can we please push this feature along to the next release or is there some reason why it has been delayed?

Updated

2 years ago
Component: Menus → WebExtensions
Product: Firefox → Toolkit
Icon display depends on your platform. On Windows and OS-X, they should always be shown. On Linux, it depends on system settings. Either way, if it works in nightly, this is not a valid bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 years ago
(In reply to Kris Maglione [:kmag] from comment #1)
> Icon display depends on your platform. On Windows and OS-X, they should
> always be shown. On Linux, it depends on system settings. Either way, if it
> works in nightly, this is not a valid bug.

I seem to remember it working in Nightly when I first started messing around with web extensions a few versions ago (I think I was using 48.* Nightly), but if it never gets pushed through to the release, it doesn't do much good.

Like I said, the SDK add-ons have no issues with icons in the context menu, so there shouldn't be a delay in getting the icons working for web extensions, especially when it is being promoted as the new standard in the near future.
(In reply to Wesley Branton from comment #2)
> (In reply to Kris Maglione [:kmag] from comment #1)
> > Icon display depends on your platform. On Windows and OS-X, they should
> > always be shown. On Linux, it depends on system settings. Either way, if it
> > works in nightly, this is not a valid bug.
> 
> I seem to remember it working in Nightly when I first started messing around
> with web extensions a few versions ago (I think I was using 48.* Nightly),
> but if it never gets pushed through to the release, it doesn't do much good.

There's no getting pushed through to release. Whatever is in nightly winds up in release three versions later.

Can you please provide an example extension that shows this issue?
(Reporter)

Comment 4

2 years ago
Here is the demo project on MDN. It will show the issue.
https://github.com/mdn/webextensions-examples/tree/master/context-menu-demo
(In reply to Wesley Branton from comment #4)
> Here is the demo project on MDN. It will show the issue.
> https://github.com/mdn/webextensions-examples/tree/master/context-menu-demo

That's fairly similar to what I tested with, but more complicated than I'd like for a testcase. Can you provide more details about your setup (preferably "Copy text to clipboard" from about:support)? And ideally as minimal a testcase add-on as possible?

Thanks.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Comment 6

2 years ago
I can also confirm this bug, tested with ff48 and 49 beta 3. the example from mdn does not display an icon on windows 8.1 and windows 10. the same code displays the icon correctly on chrome.
(Reporter)

Comment 7

2 years ago
(In reply to Kris Maglione [:kmag] from comment #5)
> (In reply to Wesley Branton from comment #4)
> > Here is the demo project on MDN. It will show the issue.
> > https://github.com/mdn/webextensions-examples/tree/master/context-menu-demo
> 
> That's fairly similar to what I tested with, but more complicated than I'd
> like for a testcase. Can you provide more details about your setup
> (preferably "Copy text to clipboard" from about:support)? And ideally as
> minimal a testcase add-on as possible?
> 
> Thanks.

Here is a link to a simple test case with a context menu item that doesn't have a function: https://drive.google.com/file/d/0B7jLBlLLhEm2d0hFQVlVWEp5UDg/view

My setup is Windows 10 on Firefox 48. I have no add-ons installed because it is a clean test profile that I use for developing add-ons. My user agent is Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

Updated

2 years ago
Component: WebExtensions → WebExtensions: Frontend

Updated

2 years ago
Keywords: qawanted

Comment 8

2 years ago
Krupa: do you know why this was set to qawanted, maybe to get a sample test case? Not sure.
Flags: needinfo?(krupa.mozbugs)

Comment 9

2 years ago
I tested several WebExtensions but this issue could only be reproduced with the WebExtension from this link: https://drive.google.com/file/d/0B7jLBlLLhEm2d0hFQVlVWEp5UDg/view.

The issue was reproduced on Firefox 52.0a1 (2016-09-21), Firefox 51.0a2 (20160921004005),  Firefox 50.0b1 (20160920155715) and Firefox 49.0 (20160916101415) under Windows 7 64-bit.
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
Flags: needinfo?(krupa.mozbugs)
Keywords: qawanted
QA Contact: cosmin.badescu
That extension shows no icons because the icon files that it references do not exist.

Since no-one can seem to reproduce this with a valid extension, I'm going to close as WORKSFORME. Please re-open if you can provide a repeatable testcase.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-firefox49: affected → ---
status-firefox50: affected → ---
status-firefox51: affected → ---
status-firefox52: affected → ---
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

2 years ago
My test case did have an error and could not open the icons. However, it is still an issue for Firefox 49.0.

See my live add-on for an example case:
https://addons.mozilla.org/en-US/firefox/addon/temperature-converter-tool/?src=ss
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Cosmin, can you reproduce with the extension linked in comment 11? I can't.
Flags: needinfo?(cosmin.badescu)

Comment 13

2 years ago
I can reproduce the problem in Firefox 49. It works fine in 50 and up. Unless Cosmin can reproduce a problem on a Nightly, we'll close this bug.

Comment 14

2 years ago
I tested https://addons.mozilla.org/en-US/firefox/addon/temperature-converter-tool/?src=ss by loading it locally in about:debugging and by installing it from that link.

Here are the results:
Firefox 49.0 (20160916101415) - about:debugging: https://www.dropbox.com/s/8mpbnw0edtp3vqv/49.0l.gif?dl=0  and from that link: https://www.dropbox.com/s/vak13dsc679qefm/49.0a.gif?dl=0  in both cases the icon is not displayed in the context menu.

Firefox 49.0a1 (20160501030217) - about:debugging: https://www.dropbox.com/s/7hldte96og17zkf/49.0a1l.gif?dl=0  and from that link: https://www.dropbox.com/s/viyibklhic4ntfc/49.0a1a.gif?dl=0  in both cases the icon is displayed in the context menu.
				
Firefox 50.0a1 (20160614030210) - about:debugging: https://www.dropbox.com/s/gdwyxbh5v2fpmjv/50.0a1l.gif?dl=0  and from that link: https://www.dropbox.com/s/shmmxd09satedi5/50.0a1a.gif?dl=0  in both cases the icon is displayed in the context menu.

Firefox 52.0a1 (20160922030437) - about:debugging: https://www.dropbox.com/s/wxrjyx7khkk1wyt/52.0a1l.gif?dl=0  and from that link: https://www.dropbox.com/s/31p7o6sw08icsph/52.0a1a.gif?dl=0  in both cases the icon is displayed in the context menu.
Flags: needinfo?(cosmin.badescu)
Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-firefox49: --- → affected
Resolution: --- → FIXED

Comment 16

2 years ago
After another check on Firefox 52.0a1 (20160925030226) under Windows 7 64-bit and based on comment 14 this issue is verified as fixed.
Status: RESOLVED → VERIFIED
status-firefox52: --- → verified

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.