Closed Bug 1295048 Opened 4 years ago Closed 4 years ago

Youtube share mouse over misplacement

Categories

(Web Compatibility :: Desktop, defect)

Firefox 51
defect
Not set
normal

Tracking

(platform-rel +)

RESOLVED WORKSFORME
Tracking Status
platform-rel --- +

People

(Reporter: akayani, Unassigned)

References

Details

(Whiteboard: [platform-rel-Youtube])

Attachments

(4 files)

Attached image youtube share.png
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160814030203

Steps to reproduce:

Ensure you have the menus enabled
Open a Youtube page
Mouse over the share button 


Actual results:

Mouse over help is ~20 pixels too low and make selection difficult. The mouseover help flashes.


Expected results:

Mouse over placement should be above the share button.
I looked at this in Chrome and in safe mode.

In fact I checked it in both Chrome and Minefield yesterday and the issue didn't exist. I think that might have been as I used my own channel when I did the check and the extra links provided by Youtube for logged in users seem to resolve the issue.

As best I can see it appears to move the rollover down about the same amount as the menu bar is tall when active. That would make sense of why it isn't already reported if the majority aren't using the menu bar. 

It seems to be pretty consistent here. Bit odd that I've not noticed any other misplacement of rollovers.
Humm... if you watch a Youtube page you see the video load then a white space is added over the video. I look like this is where the issue is generated. 

I took out Firebug and all addon that were youtube specific and that didn't change the issue.
Attached image gap.png
Gap which is generated after video load and moves mouseovers to the wrong location.
Hi Yani,

Can you provide steps on how to access the share button from the menu bar? It works for me with the following specs: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 
but I also want to ensure I am understanding your issue correctly.
Flags: needinfo?(akayani)
Not the share button from the menu bar only the shave button with the standard windows chrome menu bar active.

This is a bit of an odd effect as I'm only seeing it maybe +70% of the time. It's something to do with the order in which items are loaded.
I disabled every addon then turned them back on one at a time, in fact I think I've turned more addon on that previously and I can't reproduce the effect. Obviously it's not in my imagination or there would be no screen grab. I'll keep looking for the trigger today.
If I play this video

https://www.youtube.com/watch?v=z0-KZS1dDyw

then at ~2sec in the wrong additional white space appears.

I closed and restarted the browser and repeated the effect.
Cleaning up the Untriaged list. If you feel this is the wrong component, please correct as needed. Thanks.
Component: Untriaged → Event Handling
Product: Firefox → Core
I'm still seeing this error and it is damn annoying. It needs to be looked at and confirmed.
platform-rel: --- → ?
Whiteboard: [platform-rel-Youtube]
So annoying... it effects every control on youTube pages. Don't let it slip past without a fix. I'll screen grab a video of this if you guys need it to see the issue.
Karl, I feel like you've looked at something like this (or maybe this) recently. Am I correct? (Tentatively moving to TE, too)
platform-rel: ? → +
Component: Event Handling → Desktop
Flags: needinfo?(kdubost)
Product: Core → Tech Evangelism
Version: 51 Branch → Firefox 51
Building a play list in youTube. The "hint" was covering 90% of the add button.
Hmm interesting I can't reproduce either but I'm on mac with Firefox Nightly.
That said there are differences in the page behavior.


1. Yani's link 
   https://www.youtube.com/watch?v=z0-KZS1dDyw

2. Gnarls Barley
   https://www.youtube.com/watch?v=bd2B6SjMh_w
   Everything plays 

if I compare the debug info for each, there are quite similar.
But when playing the Yani's link on a clean profile after 2s there's a slight page blink and a transparent purple-ish square on top of the video surface, but I think it's a different issue.

Yani 

* Does it happen when you resize the window for different form factor.
* Does it make a difference when annotations are on or off?
* Are you logged in into YouTube?
Flags: needinfo?(kdubost)
* Does it happen when you resize the window for different form factor.
* Does it make a difference when annotations are on or off?
* Are you logged in into YouTube?

None of that makes any difference. 

It happens in the last seconds of a page refresh. 

This is on Nightly

Some connection to the CSS .appbar-hidden #masthead-positioner-height-offset

It seems to be more than just simple CSS. 

It could be some javascript code in youTube that is specific to Firefox.
Ah thanks Yani.

#masthead-positioner-height-offset {
	height: 90px;
}

.appbar-hidden #masthead-positioner-height-offset {
	height: 50px;
}

because of the cascade. the 50px takes over the 90px and this 40px seems to be close to what you are experiencing for the gap.


The part of the CSS where this is happening is:
https://s.ytimg.com/yts/cssbin/www-pageframe-vflS7UaoM.css


#masthead-positioner-height-offset {
	height:90px
}
.exp-searchbox-redesign #masthead-positioner-height-offset {
	height:96px
}
.appbar-hidden #masthead-positioner-height-offset {
	height:50px;
}
.exp-searchbox-redesign.appbar-hidden #masthead-positioner-height-offset {
	height:56px
}
.sitewide-ticker-visible #masthead-positioner-height-offset {
	height:125px
}
.sitewide-consent-visible #masthead-positioner-height-offset {
	height:146px
}
.exp-searchbox-redesign.sitewide-ticker-visible #masthead-positioner-height-offset {
	height:131px
}
.sitewide-ticker-visible.appbar-hidden #masthead-positioner-height-offset {
	height:85px
}
.sitewide-consent-visible.appbar-hidden #masthead-positioner-height-offset {
	height:106px
}
.exp-searchbox-redesign.sitewide-ticker-visible.appbar-hidden #masthead-positioner-height-offset {
	height:91px
}


The appbar-hidden is set through
https://s.ytimg.com/yts/jsbin/www-pageframe-vflo9ZRlQ/www-pageframe.js

    function Ko() {
        var a = A(document.body, "appbar-hidden"),
            b = Le(Do).B,
            c = Ne(Do).height;
        hp = a ? b + c : b + c - 40
    }

The code is not specific to Firefox, it goes through on Safari. 
I tried with Firefox Nightly 52.0a1 (2016-10-23) (64-bit) on MacOSX **clean profile** no addons, no blocking with non e10s window, with private window (tracking protection on).

And I'm still unable to reproduce. :/ 



There is probably something I'm missing. Let's go back to 

"Ensure you have the menus enabled"

What do you mean by this? Which steps do you take to do that?
It happens with the menus on and off. So I don't think that is the issue. (standard windows menus)

If I correct the CSS, the position of the roll overs is still out.

The bit of space is just that. The issue is the misplacement of the rollovers which in some case near covers the entire button. 

I'd say it was an error via JavaScript as it occurs late in the page loading.

Minefield
"Use of attributes’ nodeValue attribute is deprecated. Use value instead."

Chrome
"VM216:1 'webkitIDBFactory' is deprecated. Please use 'IDBFactory' instead."


If the issue is the youtube code, and it may well me, then let's confirm that and report to them.
This doesn't reproduce for me in Nightly or Release on my Windows 10 machine.

Yani, can you test again?
When I looked yesterday the issue mentioned was gone and been replaced with a new issue where the top of the videos is trimmed off. 

I only noticed as the video I was watching had text at the top. 

Say this video... https://youtu.be/Qfcejpl0it4

Check the top of head to top of video then go full screen to see the amount that should not have been  trimmed
Attached image Trim issue in youTube
> When I looked yesterday the issue mentioned was gone and been replaced with a new issue where the top of the videos is trimmed off. 

OK, can you file a new issue for that? Let's go ahead and resolve this one.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
See Also: → 1320599
Flags: needinfo?(akayani)
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.