Do not check IMAP accounts for new mail if Mail is closed

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Reid Holmes, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020305
BuildID:    2002030508

After mail is closed it seems to continue to poll IMAP accounts.  

Reproducible: Always
Steps to Reproduce:
1. Open mailnews and check an imap account (with turbo enabled).
2. Close mail.
3. Open account using pine.
4. Wait until recheck interval has passed; Pine will report that session is now
read-only because another process is accessing the folder.

Actual Results:  Mailnews seems to be checking the accounts after it has been
closed.

Expected Results:  Once mail is closed it should stop checking.

If quicklaunch is closed and all mozilla instances are exited the interruptions
cease to happen.
to get that error message, do you have to run mozilla on the same machine that
you run pine?
I wonder if we could use something like netstat to see if our application has
any open connections to the imap server, instead of having to see if pine
detects them.
(Reporter)

Comment 3

16 years ago
I've talked to a few people and I'm wondering if this is anticipated
functionality.  I've been told that if you open mozilla, then check your mail,
and close mail but not the browsers etc. that your mail should still be checked.
 Is this correct?  The scenario I described had mozilla and the imap server
being seperate machines.  I would test with netstat but I do not have access to
the machines set up with this configuration right now.

Comment 4

16 years ago
So, does this still happen with a recent build?

-M

Updated

16 years ago
QA Contact: huang → gchan

Updated

16 years ago
Summary: imap accounts polled after mail closed if turbo enabled → Do not check IMAP accounts for new mail if Mail is closed
no answer
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.