Live air.mozilla.org video does not play on Linux

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: botond, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
STR:
  1. Run Nightly on Linux (I'm running Debian stable)
  2. Go to air.mozilla.org
  3. Play a video that's currently streaming live
     (such as the internal meeting at the time of filing this bug)

Expected results:
  The video plays.

Actual results:
  The video's title screen is shown. Three dots over it animate
  once, then disappear. The video does not play.

Playing a previously recorded (i.e. non-live) video works fine.

Playing the live video works fine in Firefox Release.

Playing the live video works fine in Firefox Nightly on Windows.
Flags: needinfo?(jyavenard)
Could you run mozregression to find out what broke it?

Having said that.. Which version of ffmpeg do you have installed?
Flags: needinfo?(jyavenard) → needinfo?(botond)
(Reporter)

Comment 2

2 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #1)
> Which version of ffmpeg do you have installed?

botond@botond-desktop:~$ dpkg -l | grep libavcodec
ii  libavcodec56:amd64                    6:11.7-1~deb8u1                      amd64        Libav codec library

(In reply to Jean-Yves Avenard [:jya] from comment #1)
> Could you run mozregression to find out what broke it?

I can try. Of course, I can only do it while a live video is streaming...
(Reporter)

Comment 3

2 years ago
(In reply to Botond Ballo [:botond] from comment #2)
> (In reply to Jean-Yves Avenard [:jya] from comment #1)
> > Could you run mozregression to find out what broke it?
> 
> I can try. Of course, I can only do it while a live video is streaming...

Hmm, I actually couldn't reproduce it with Nightly in a clean profile. Makes me wonder if it's add-on related.

Unfortunately, the only video that was currently live-streaming just ended, so I'll have to resume testing later.
Flags: needinfo?(botond)
(Reporter)

Comment 4

2 years ago
(In reply to Botond Ballo [:botond] from comment #3)
> Hmm, I actually couldn't reproduce it with Nightly in a clean profile. Makes
> me wonder if it's add-on related.

And today, I can't reproduce it in my regular profile, either. Perhaps it depends on the video, then.
(Reporter)

Comment 5

2 years ago
I'm going to close this as WORKSFORME. If I see it again, I'll reopen and get a regression window immediately (while the problematic video is still live-streaming).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

2 years ago
This is happening again, with the current monthly internal call.

Interestingly, it does not happen in a new profile, but does happen in my regular profile, even in Safe Mode. I'm not really sure what is different between a profile in Safe Mode and a new profile...
(Reporter)

Comment 7

2 years ago
Interestingly, the project call works even in my regular profile...
You need to log in before you can comment on or make changes to this bug.