cut and paste cells from google sheet into gmail

RESOLVED FIXED

Status

()

Core
Editor
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: emceeaich, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(platform-rel +, firefox51 affected)

Details

(Whiteboard: [platform-rel-Google][platform-rel-Gmail][platform-rel-GoogleSuite][platform-rel-GoogleSheets])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160815030201

Steps to reproduce:

Cut cells from Google Sheet and pasted into gmail

https://docs.google.com/spreadsheets/d/1_4uaCuCygQfLC-7BVsc86sU-WoU0Ifl93E0Uz1Gym3E/edit#gid=1668699827


Actual results:

Browser hung, necessitating restart


Expected results:

Cells should had been pasted into Gmail
status-firefox51: --- → affected
platform-rel: --- → ?
Whiteboard: [platform-rel-Google][platform-rel-Gmail][platform-rel-GoogleDocs][platform-rel-GoogleSheets]
Whiteboard: [platform-rel-Google][platform-rel-Gmail][platform-rel-GoogleDocs][platform-rel-GoogleSheets] → [platform-rel-Google][platform-rel-Gmail][platform-rel-GoogleSuite][platform-rel-GoogleSheets]
platform-rel: ? → +
Michael, can you investigate? Since Sheets uses canvas I'm not sure this is an Editor bug but maybe it is on the pasting side (GMail)?
Flags: needinfo?(michael)
Emma, this works for me in both e10s and non-e10s in 51 and above. Can you see if this works for you now?
Flags: needinfo?(michael) → needinfo?(ehumphries)
I can confirm this is working in 52.0a1 (2016-11-07) (64-bit) on MacOS 10.12
Flags: needinfo?(ehumphries)
\o/

(Michael, any idea what bug(s) we can reference here as the fix(es)?)
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Flags: needinfo?(michael)
Resolution: --- → FIXED
I'm not sure what would have fixed this issue. The changes which I have made recently to DnD all have to do with how images and files are handled, and I don't imagine that that would affect this too much.
Flags: needinfo?(michael)
You need to log in before you can comment on or make changes to this bug.