Closed Bug 1295321 Opened 3 years ago Closed 3 years ago

New debugger should work with light/dark theme

Categories

(DevTools :: Debugger, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1301207

People

(Reporter: jlong, Unassigned)

References

Details

Attachments

(1 file)

The new debugger should render with both the light and dark theme correctly, and support dynamically switching between them at runtime.

We probably should just copy the entire bundle of CSS files for both themes. Right now we only copy the "base" file but not any of its dependents, so we are missing a bunch of stuff. Let's make sure it renders correctly with these CSS files in Firefox, and go from there. We'll probably have to fix up some stuff in Chrome because these CSS files are Firefox-specific.
Blocks: 1294139
Priority: -- → P2
Attached image current-dark-theme.png
Screenshot of current dark theme in toolbox for reference
This is a dupe now. The relevant changes have been made in the debugger, and while it needs tweaks, it's a lot closer.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1301207
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.