Intermittent dom/network/tests/test_tcpsocket_jsm.html | Test timed out.

RESOLVED DUPLICATE of bug 1295453

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1295453
2 years ago
2 years ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Component: Networking → DOM

Comment 1

2 years ago
17 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 12
* mozilla-central: 3
* fx-team: 1
* autoland: 1

Platform breakdown:
* linux64: 12
* osx-10-10: 4
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-19&endday=2016-08-19&tree=all

Comment 2

2 years ago
51 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 22
* mozilla-inbound: 15
* fx-team: 6
* try: 4
* mozilla-central: 4

Platform breakdown:
* linux64: 24
* osx-10-10: 21
* windows7-32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-15&endday=2016-08-21&tree=all
This is a timeout in the new test added in bug 1104156. Either closeImmediately threw an exception (I'm not sure what would happen, in that case), or we yield indefinitely waiting for at least 1 byte of data that never arrives.

Comment 4

2 years ago
Are these test failing on some specific OS or they are failing in general?
Flags: needinfo?(josh)
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483 shows intermittent failures on all major OSes.
Flags: needinfo?(josh)
I added a `throw TypeError("hi")` to the same code that calls closeImmediately and got different output, so we can ignore closeImmediately.

Comment 7

2 years ago
28 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 14
* autoland: 8
* mozilla-central: 6

Platform breakdown:
* linux64: 23
* osx-10-10: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-22&endday=2016-08-22&tree=all

Comment 8

2 years ago
19 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 7
* autoland: 6
* mozilla-central: 3
* fx-team: 3

Platform breakdown:
* linux64: 14
* osx-10-10: 4
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-23&endday=2016-08-23&tree=all

Comment 9

2 years ago
(In reply to Josh Matthews [:jdm] from comment #6)
> I added a `throw TypeError("hi")` to the same code that calls
> closeImmediately and got different output, so we can ignore closeImmediately.

So it has nothing to do with our new Implementation for closeImmediately.
Well, CloseImmediately may be implemented in a way that occasionally causes our new test to time out, rather than receive any data at all. I'm not sure yet.

Comment 11

2 years ago
When it would not get that 1 byte of data (In reply to Josh Matthews [:jdm] from comment #10)
> Well, CloseImmediately may be implemented in a way that occasionally causes
> our new test to time out, rather than receive any data at all. I'm not sure
> yet.

CloseImmediately can cause time out when it waits for that 1 byte of data and it does not receive that, it would wait for it indefinitely.

Comment 12

2 years ago
20 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 8
* autoland: 7
* fx-team: 3
* mozilla-central: 2

Platform breakdown:
* linux64: 17
* windows7-32: 2
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-24&endday=2016-08-24&tree=all

Comment 13

2 years ago
29 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 15
* autoland: 13
* try: 1

Platform breakdown:
* linux64: 23
* osx-10-10: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-25&endday=2016-08-25&tree=all

Comment 14

2 years ago
33 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 15
* autoland: 9
* fx-team: 4
* try: 3
* mozilla-central: 2

Platform breakdown:
* linux64: 23
* osx-10-10: 8
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-26&endday=2016-08-26&tree=all

Comment 15

2 years ago
132 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 58
* autoland: 45
* mozilla-central: 13
* fx-team: 12
* try: 4

Platform breakdown:
* linux64: 101
* osx-10-10: 25
* windows7-32: 5
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-22&endday=2016-08-28&tree=all

Comment 16

2 years ago
26 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 13
* autoland: 10
* mozilla-central: 3

Platform breakdown:
* linux64: 20
* osx-10-10: 4
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-29&endday=2016-08-29&tree=all

Comment 17

2 years ago
22 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 10
* mozilla-inbound: 7
* try: 3
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* linux64: 18
* osx-10-10: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-30&endday=2016-08-30&tree=all
AFAICT this is indeed just a duplicate of bug 1295453 (it's arbitrary which is the duplicate of which, but I think bug 1295453's summary more closely indicates the root cause)
Figured out how to dupe this bug in a starring-friendly way, doing so.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1295453
Keywords: intermittent-failure

Comment 20

2 years ago
19 automation job failures were associated with this bug yesterday.

Repository breakdown:
* autoland: 9
* mozilla-inbound: 7
* mozilla-central: 2
* fx-team: 1

Platform breakdown:
* linux64: 17
* osx-10-10: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-31&endday=2016-08-31&tree=all

Comment 21

2 years ago
67 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 29
* mozilla-inbound: 27
* mozilla-central: 6
* try: 3
* fx-team: 2

Platform breakdown:
* linux64: 55
* osx-10-10: 10
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1295483&startday=2016-08-29&endday=2016-09-04&tree=all
You need to log in before you can comment on or make changes to this bug.