IFRAME links replacing entire window regardless of target

RESOLVED WORKSFORME

Status

()

Core
Layout: HTML Frames
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Eric Means, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Links in IFRAMEs take over the whole window, instead of just loading in the IFRAME.

See bug 107682 for a similar bug (on MacOS).


Reproducible: Always
Steps to Reproduce:
1. Go to http://arstechnica.infopop.net/OpenTopic/page?a=tpc&s=50009562&f=51009562&m=3640928593
2. (you may have to create an account (free reg)/login)
3. Hit the Reply button
4. In the IFRAME at the bottom, click any link, for example the Reply button.

Actual Results:  The link will open in the full window.

Expected Results:  The link should open in the IFRAME.

According to the second post in that thread, it works in 0.9.8/OSX.  It does not work correctly in 0.9.8/Windows 2000 Pro SP2.  The only bug I've been able to find that addressed this problem was 107682, here: http://bugzilla.mozilla.org/show_bug.cgi?id=107682

That bug was reported from a Mac running OS9 and later reported to actually be working correctly in that instance, so I suspect this to be a Windows-specific bug.

Comment 1

16 years ago
  When I hit the reply button at the top of the Iframe the link is opened in the 
Iframe itself. Its not opening in the full window. Works for me.

Build ID: 2002030403
Platform : win2k
WORKSFORME, fresh Linux CVS.  Resolving.  Reporter: please re-open the bug if
you still see the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.