selection lost after clearing quick search

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
2 years ago
3 months ago

People

(Reporter: avi.kivity, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.106 Safari/537.36

Steps to reproduce:

1. type some characters in the quick search box ("Filter these messages")
2. Select a message
3. Click the backspace button to clear the search box


Actual results:

Selection is lost


Expected results:

Selection should not have been lost, so I can continue to work on my message.

This is important when an email thread has emails with different subjects.  While the search is active, I don't see all messages in the thread.  When the search is cleared, my selection is lost.

Comment 1

2 years ago
I can't reproduce this. 
Did it happen prior to version 45?
Does it only when using backspace, i.e. not when say hitting escape?
Component: Untriaged → Search
Whiteboard: [closeme 2016-12-21]

Comment 2

2 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2016-12-21]
(Reporter)

Comment 3

2 years ago
I'm not sure whether it happened before 45.

I reproduced it again, on 45.7.0.

Steps:

1. Quick filter
2. Type some word
3. Expand thread
4. Select some message
5. "Quick filter" again to go back to full view OR hit the delete button in the filter bar

Result: selection is lost.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

3 months ago
Whiteboard: [dupme]
You need to log in before you can comment on or make changes to this bug.