Don't close the urlbar popup when pressing left/right arrow keys

RESOLVED FIXED

Status

()

defect
P2
normal
RESOLVED FIXED
3 years ago
5 months ago

People

(Reporter: adw, Unassigned)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 wontfix)

Details

(Whiteboard: [fxsearch] fixed in quantumbar)

Stephen and I were discussing the tab/arrrow key behavior re: the one-off search buttons, and he mentioned that the popup shouldn't close when you press the left/right arrow keys.  The caret in the text field should simply move left/right, as it does now, but without closing the popup.
I think the reason we close the popup atm, is that in case of autofill LEFT/RIGHT/HOME/END actually confirm the suggestion, and by doing so the searched text changes and previous results are, technically, no more valid.
This may be as easy as setting "norolluponanchor" attribute, but it will probably have consequences on autoFill and automated tests that should be verified. Very likely it will require changes to the autocomplete controller since norollup was never tested with the location bar.
Priority: P1 → P2
Note that Cliqz also wants this same behavior, so it would be nice to fix this.
Blocks: 1379431
It would be good if we could fix both this bug and bug 1379431 at the same time.
This is fixed in the current quantumbar implementation.
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Depends on: quantumbar
Whiteboard: [fxsearch] → [fxsearch] fixed in quantumbar
Duplicate of this bug: 1525344
You need to log in before you can comment on or make changes to this bug.