Multiple select vertical scrollbar is hidden in Firefox 45.3.0 on Mac OS 10.11.6

RESOLVED INVALID

Status

()

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: aneesakunju, Unassigned)

Tracking

45 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160725105554

Steps to reproduce:

<select id="mymultsel" class="listbox" multiple="" size="4"  tabindex="7" name="mymultsel" style="cursor:pointer;">
  <option value="1" selected="">bedroom</option>
  <option value="2" style="cursor:pointer;">bathroom</option>
  <option value="3" style="cursor:pointer;">hall</option>
 <option value="4" style="cursor:pointer;">hall4</option>
  <option value="5" style="cursor:pointer;">hall5</option>
  <option value="6" style="cursor:pointer;">hall6</option>
  <option value="7" style="cursor:pointer;">hall7</option>
  <option value="8" style="cursor:pointer;">hall8</option>
  <option value="9" style="cursor:pointer;">hall9</option>
</select>
For the CSS:
element.style {
  cursor:pointer;
}
.listBox {
  font: 75%/110% tahoma;
  width: 30ex;
}



Actual results:

The vertical scrollbar doesn't show up on some Macs and shows up on others, even though we are using the same OS version/browser version/default Firefox theme. All I see are the first 4 options. There's no sign of any vertical scrollbar on the right. 


Expected results:

The scrollbar should show up as the size is less than the no of elements.

Comment 1

2 years ago
Created attachment 8781969 [details]
1295752.html

Updated

2 years ago
OS: Unspecified → Mac OS X

Comment 2

2 years ago
tracy, could you confirm the issue of the reporter on OSX, please?
Component: Untriaged → Widget: Cocoa
Flags: needinfo?(twalker)
Product: Firefox → Core
We're up to 48 on release.

This works for me:
Mac OSX 10.11:  Nightly 51.0a1, 20160816030459 and release Firefox 48.0, 20160726073904. PASS
Win 7:  Nightly 51.0a1, 20160816030459 and release Firefox 48.0, 20160726073904. PASS

Safna, please try with current release Firefox 48.0.  If you can reproduce with that build, please attach your about:support and re-open the bug. For now INVALID as we won't address any issue that might be on 45 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(twalker) → needinfo?(aneesakunju)
Resolution: --- → INVALID

Comment 4

2 years ago
Tracy, I think the reporter is using ESR 45.3.0, which is supported. ;)
https://www.mozilla.org/en-US/firefox/organizations/all/
WFM there as well.  

Mac OSX 10.11:  Firefox esr 45.3.0 20160725105554. PASS
(Reporter)

Comment 6

2 years ago
It works for me (reporter) as well. But it doesn't work for some people who have the same setup.
(In reply to Aneesa from comment #6)
> It works for me (reporter) as well. But it doesn't work for some people who
> have the same setup.

They may be running add-ons or have some other configuration that is interfering.  Please have those affected by this bug post their about:support. Thanks
(Reporter)

Comment 8

2 years ago
Created attachment 8782056 [details]
about:support

about:support attached from the mac having issues.
(Reporter)

Comment 9

2 years ago
This issue has been solved for the Mac whose about:support i attached. He actually sees the scrollbar when he swipes downward on the trackpad with 2 fingers, because he's in showScrollbars=AutomaticallyBasedOnMouseOrTrackpad. However, in this mode, he was not seeing the scrollbar when he had his mouse over the scrollbar. I had him update to showScrollbars=Always, and now he sees it all the time.
Thank you for followups. I am not familiar with showScrollbars=AutomaticallyBasedOnMouseOrTrackpad.  Where is that set?  I am curious and want to attempt to reproduce.
(Reporter)

Comment 11

2 years ago
Mac->System Preferences->General->Show Scroll Bar
Hmmm, "Always" and "Automatically based on mouse or trackpad" seem to be the same. In both cases, scroll bars are always shown. So the Automatic setting seems to be broken. Perhaps there is some other setting overriding Automatic?

If Show scroll bars: is set to "When scrolling,"  then the scroll bars don't appear for mouse hover. They appear only when actually scrolling with the trackpad or mousewheel.  Which I think is expected.  

With each setting Firefox behaves the same as Safari.
Note that if an external mouse is connected, scrollbars are always shown if set to "Automatically based on mouse or trackpad".
Flags: needinfo?(aneesakunju)
(In reply to Stephen A Pohl [:spohl] from comment #13)
> Note that if an external mouse is connected, scrollbars are always shown if
> set to "Automatically based on mouse or trackpad".

Ah.  so when mouse is connected scroll bars show always. ok, that works as expected. 

With no mouse connected, scroll bars show only when actually trackpad scrolling. Pointer hover does not expose the scroll bars.  Stephen, is that latter point expected? I suspect this is all expected behavior and invalid remains correct resolution for this report.
Yes, this is expected behavior and matches Safari. There are other bugs, such as bug 946571 where we fail to show scrollbars when we should. But this bug here is correctly resolved as invalid.
You need to log in before you can comment on or make changes to this bug.