Our import of CSS-Values-3 reftests is missing some subdirectories ("iframe" and "reference")

RESOLVED DUPLICATE of bug 1256580

Status

RESOLVED DUPLICATE of bug 1256580
2 years ago
2 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
CSS-Values-3 reftests use a few helper-files that live in subdirectories called "iframe" and "reference", shown here:
  https://github.com/w3c/csswg-test/tree/master/css-values-3

We don't currently import those subdirectories, though -- we only import "support":
https://dxr.mozilla.org/mozilla-central/source/layout/reftests/w3c-css/received/css-values-3

Perhaps we should import those other subdirectories? (Or: perhaps the tests need to be rewritten such that all of their resources live in "support/"?  At first I thought there was a requirement to that effect, but I can't find any such requirement on http://testthewebforward.org/docs/reftests.html at the moment.)
(Reporter)

Comment 1

2 years ago
We do have some imported tests that reference files in these subdirectories -- e.g. this one:
https://dxr.mozilla.org/mozilla-central/rev/054d4856cea6150a6638e5daf7913713281af97d/layout/reftests/w3c-css/received/css-values-3/vh-support-transform-origin.html#39
> 	<iframe src="iframe/vh-support-transform-origin.html"></iframe>
...though this test is marked "skip" at the moment:
https://dxr.mozilla.org/mozilla-central/rev/054d4856cea6150a6638e5daf7913713281af97d/layout/reftests/w3c-css/received/reftest.list#97
...perhaps because it fails due to this missing helper-file (not sure).
(In reply to Daniel Holbert [:dholbert] from comment #1)
> ...perhaps because it fails due to this missing helper-file (not sure).

That's right. It's bug 1256580. See https://dxr.mozilla.org/mozilla-central/rev/054d4856cea6150a6638e5daf7913713281af97d/layout/reftests/w3c-css/failures.list#29-31
Oh, I guess actually this is a duplicate of that bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256580
(Reporter)

Comment 5

2 years ago
Ah, looks like it. Thanks!
You need to log in before you can comment on or make changes to this bug.