Service-Worker stopping unexpectedly (maybe website issue, not sure)

RESOLVED WORKSFORME

Status

()

Core
DOM: Service Workers
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: patrickalbrecht1996, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160811031722

Steps to reproduce:

Tested with a fresh profile of course :)
1) Go to https://www.computerbase.de/push/ and activate Web Push
2) Go to about:debugging#workers in a new tab and verify that the Service-Worker run
3) Close the computerbase tab
4) Open an other news page like http://www.heise.de


Actual results:

The Serivce-Worker stopp to run.


Expected results:

The Service-Worker should still run, as I expect and as mention in the FAQ:
Desktop-Browser müssen grundsätzlich geöffnet sein, ein ComputerBase-Tab muss darin aber nicht existieren. (The Browser has to be open, but no ComputerBase-Tab have to be open.)
(Reporter)

Comment 1

2 years ago
Addiontal Information:
I'm not sure if this is a FF issue or a Site specific issue, but as I don't see any negative feedback on the Site, I guess it's a real issue.
I'm behind a proxy.
Running FF 49.0b3 on a Windows 7 Pro x86
Firefox is not installed in the default path, but still under C:\Program Files. (correctly under C:\Program Files\MFirefox)
Component: Untriaged → DOM: Service Workers
Product: Firefox → Core
(In reply to patrickalbrecht1996 from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0
> Build ID: 20160811031722
> 
> Steps to reproduce:
> 
> Tested with a fresh profile of course :)
> 1) Go to https://www.computerbase.de/push/ and activate Web Push
> 2) Go to about:debugging#workers in a new tab and verify that the
> Service-Worker run
> 3) Close the computerbase tab
> 4) Open an other news page like http://www.heise.de
> 
> 
> Actual results:
> 
> The Serivce-Worker stopp to run.
> 

Hi, 
Would you please elaborate more on how you tested if the service worker stopped running or not? I guess you were telling it from the existence of "Start" icon on |about:debugging#workers|? Thank you!


> 
> Expected results:
> 
> The Service-Worker should still run, as I expect and as mention in the FAQ:
> Desktop-Browser müssen grundsätzlich geöffnet sein, ein ComputerBase-Tab
> muss darin aber nicht existieren. (The Browser has to be open, but no
> ComputerBase-Tab have to be open.)
Flags: needinfo?(patrickalbrecht1996)
(Reporter)

Comment 3

a year ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #2)
> Hi, 
> Would you please elaborate more on how you tested if the service worker
> stopped running or not? I guess you were telling it from the existence of
> "Start" icon on |about:debugging#workers|? Thank you!
Hi,
Your supposition is correct, I'm seeing the _Start_ Button again.
(Reporter)

Updated

a year ago
Flags: needinfo?(patrickalbrecht1996)
The service worker will be stopped after it has been idle for a certain period of time.  This is normal and expected.  It will automatically be restarted if a new push event or other event needs to be fired on the service worker.

You can see this in action by doing this:

1) Open https://gauntface.github.io/simple-push-demo/
2) Enable push notifications
3) Accept the permission
4) Click "send push via xhr"
5) Open about:debugging in another tab
6) Observe that the service worker is running
7) Wait for the service worker to stop (about 30 seconds)
8) Click "send push via xhr" again
9) Observe that the service worker has started again

Does this work for you?
Flags: needinfo?(patrickalbrecht1996)
(Reporter)

Comment 5

a year ago
Thank you for your step-by-step instructions, it works for me.

As the service workers components works in FF, I need to contact the site operator again, hopefully he can fix the issue on his site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(patrickalbrecht1996)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.