[TEXT] delete text with negative char spacing doesn't display correctly

RESOLVED WONTFIX

Status

()

Core
Layout
P4
normal
RESOLVED WONTFIX
19 years ago
16 years ago

People

(Reporter: buster, Assigned: Frank Tang)

Tracking

Trunk
Future
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
open sample 0
turn on edit mode
select at the end of the paragraph that has negative character spacing on the
first line
start backspacing
when you get to a single line of text, notice the display turds left where the
characters used to be

Updated

19 years ago
Assignee: kipp → troy

Comment 1

19 years ago
I suspect troy will be able to fix this up lickety split since it has to (most
likely) do with incremental reflow and insufficient invalidation...

Updated

19 years ago
Assignee: troy → kipp

Comment 2

19 years ago
Kipp, as Steve indicated this problem only happens when there's negative spacing
involved. It looks to me like maybe the line's "combined rect" is incorrect in
that case and that's why we end up not erasing everything

The block code in ReflowLine() is erasing everything, because we really don't
know what changed:

    // We don't really know what changed in the line, so use the union
    // of the old and new combined areas
    if (aDamageDirtyArea) {
      nsRect  dirtyRect;

      dirtyRect.UnionRect(oldCombinedArea, aLine->mCombinedArea);
      Invalidate(dirtyRect);
    }

I would guess the problem is wherever we handle negative character spacing.
Maybe it's round off error?

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 3

19 years ago
I hate bouncing bugs. Oh well.

Comment 4

19 years ago
Well, I can't reproduce it on linux, so it'll have to wait until I have access
to a windoze box to see whats up...

Comment 5

18 years ago
Updating to default Layout Assignee...kipp no longer with us :-(

Comment 6

18 years ago
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
(Reporter)

Updated

18 years ago
Priority: P3 → P4
Summary: delete text with negative char spacing doesn't display correctly → [TEXT] delete text with negative char spacing doesn't display correctly
(Reporter)

Comment 7

18 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
(Reporter)

Comment 8

18 years ago
Here is the initial batch of layout [TEXT] bugs.  I'll search for more today, 
but this should keep you busy for a while!

Please review these for possible dogfood or nsbeta2 candidates, and assign your 
own priority and milestone for each.  The current settings were relative to my 
bug list, and they might not make sense any more.
Assignee: buster → erik

Comment 9

18 years ago
I confirmed that this bug still exists. Marking M19.
Status: NEW → ASSIGNED
Target Milestone: M17 → M19
(Assignee)

Comment 10

17 years ago
Mark this as future since no real user will use negative char spacing in real 
life and edit them anyway.
Target Milestone: --- → Future
(Assignee)

Comment 11

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW
(Assignee)

Comment 12

17 years ago
mark all future new as assigned after move from erik to ftang
Status: NEW → ASSIGNED
(Assignee)

Comment 13

16 years ago
mark this bug as wontfix
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.