Include JS stacks in controlled crash report

RESOLVED DUPLICATE of bug 1295918

Status

()

Toolkit
Crash Reporting
RESOLVED DUPLICATE of bug 1295918
2 years ago
2 years ago

People

(Reporter: kanru, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
For crashes created in a controlled way like MOZ_CRASH, MOZ_ASSERT, NS_RUNTIMEABORT it might be worth to include the current JS stacks of the crashing thread to aid debugging.

Full JS stacks might include content provided scripts which I think are PII so we should only show the stacks from chrome by default.

It looks xpc_PrintJSStack allocates memory so we can't use it in OOM situation. Otherwise I assume it's quite safe to use it from MOZ_CRASH as long as we can avoid recursive MOZ_CRASH in xpc_PrintJSStack.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1295918
No longer blocks: 1289663
You need to log in before you can comment on or make changes to this bug.