Closed Bug 1295922 Opened 5 years ago Closed 5 years ago

webkitdirectory custom UI does not work.

Categories

(Core :: DOM: Core & HTML, defect)

50 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox50 + fixed
firefox51 + fixed

People

(Reporter: qab, Assigned: smaug)

Details

Attachments

(2 files, 1 obsolete file)

Attached file q.html
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

Open attached PoC.

1. Click on the folder uploader directly, a normal folder upload appears.

2. Click on the 'custom UI' button, a file picker appears instead of a folder picker.


Actual results:

Does not seem like its possible to have custom UI for folder upload. This breaks the folder upload feature on Google Drive for example.


Expected results:

A folder picker should have appeared when clicking the Custom UI button.
Flags: needinfo?(amarchesini)
[Tracking Requested - why for this release]:
We're trying to get webkitdirectory to FF50, and looks like this is incompatibility with Chrome implementation.
HTMLInputElement::MaybeInitPickers is wrong.
I guess I can take this.
Assignee: nobody → bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(amarchesini)
Attached patch patch (obsolete) — Splinter Review
Attachment #8781994 - Flags: review?(amarchesini)
Attachment #8781994 - Flags: review?(amarchesini) → review+
Approval Request Comment
[Feature/regressing bug #]: bug 1288683 enabled the API, but the buggy code is from bug 1164310
[User impact if declined]: Some websites might not work
[Describe test coverage new/current, TreeHerder]: manual testing
[Risks and why]: Should be very safe
[String/UUID change made/needed]: NA



m-i is closed atm, so exported the patch here.

We could simplify that code a bit more, but since we want to land this to Aurora too, I kept the changes absolutely minimum.
Attachment #8782017 - Flags: approval-mozilla-aurora?
Keywords: checkin-needed
Component: Untriaged → DOM
Product: Firefox → Core
Version: 51 Branch → 50 Branch
Attachment #8781994 - Attachment is obsolete: true
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/13d7c16e0442
<input type=file webkitdirectory>.click() doesn't work. r=baku
Keywords: checkin-needed
Tracking 50/51+ since this might break some websites.
https://hg.mozilla.org/mozilla-central/rev/13d7c16e0442
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Comment on attachment 8782017 [details] [diff] [review]
with commit message

Webkitdirectory is planned for Fx40, Aurora50+
Attachment #8782017 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.