Make it possible to use "Backfill" and "Add new jobs" in treeherder to schedule an Autophone job

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
2 years ago
8 months ago

People

(Reporter: dminor, Unassigned)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
It would be nice to be able to use "Add new jobs" in treeherder to schedule an Autophone job rather than having a wait for a new android build.

Comment 1

2 years ago
Which pulse exchange do the messages appear? exchange/treeherder-stage/v1/job-actions ? What do they look like?
the pulse actions code is here:
https://github.com/mozilla/pulse_actions/tree/master/pulse_actions

I assume we will need some pulse_actions modifications to get the valid list of job names, possibly some minor treeherder modifications, and maybe any changes to autophone.  I think autophone could listen to a specific type of pulse message to request a new job and we would be all good.

Comment 3

2 years ago
It is not a "job action" but a "resulset action".
I've added information for it in here:
https://wiki.mozilla.org/Auto-tools/Projects/Pulse/Exchanges#Resultset_Actions

Comment 4

2 years ago
I don't think changes on pulse_actions is needed to get something going.

However, notice that with pulse_actions we create an Sch/A job on Treeherder that would reveal if something has gone wonky in processing the request. The code for that logic is very simple if we want to give it to Autophone.

We can also implement this on pulse_actions if I have an API on autophone for me to use.

Updated

a year ago
Duplicate of this bug: 1373856

Updated

a year ago
Summary: Make it possible to use "Add new jobs" in treeherder to schedule an Autophone job → Make it possible to use "Backfill" and "Add new jobs" in treeherder to schedule an Autophone job

Comment 6

8 months ago
Autophone is going away. Resolving these to wontfix.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.