many sites on android end up selecting element instead of triggering click interaction

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-all][needsdiagnosis])

(Reporter)

Description

a year ago
With FF48 I've noticed an increase in sites where I end up selecting an element when I try to interact with the page.  For example:

1) Open https://dial.uber.com
2) Tap "Start Riding" button
3) When it opens the next page, tap the arrow to go back in upper left
4) Observe the arrow div is selected instead of triggering the interaction

Or

1) Open http://projects.fivethirtyeight.com/2016-election-forecast/
2) Try to switch from the "poll-only forecast" with the combo box in the bottom left.
3) Observe that some element is selected instead of interacting with the combo box when you tap on it.
(Reporter)

Comment 1

a year ago
Mike, can you tell if this is a web compat thing or a browser bug?  It feels like it started in FF48 for me, but maybe I just started visiting these sites at the same time.
Flags: needinfo?(miket)

Comment 2

a year ago
Hi Ben,

I tried it on Chrome and on https://dial.uber.com it behaves the same as on FF 48,49,50 and 51. The interaction with the arrow is not triggered. So here i think it's not a browser bug.

But http://projects.fivethirtyeight.com/2016-election-forecast/ on Chrome it work fine, you can switch from the combo boxes. The device is Galaxy Note 5(6.0.1).
(Sorry for slow replies, PTO + conference travels!)

Yeah, for the uber example, it looks like they've just forgotten to register event handlers for the SVG arrow. Busted everywhere I tested.

I can reproduce the fivethirtyeight.com bug, settings needsdiagnosis and hopefully will have more time tomorrow to dig in.
Flags: needinfo?(miket)
Whiteboard: [country-all][needsdiagnosis]
(Reporter)

Comment 4

a year ago
I also got the "selection instead of interaction" on mobile.twitter.com new tweet button.  Tried a second time and it worked.
https://github.com/webcompat/web-bugs/issues/2417 is possibly related. Still flying around the globe -- hope to dig in soon.
(In reply to Mike Taylor [:miketaylr] from comment #5)
> https://github.com/webcompat/web-bugs/issues/2417 is possibly related. Still
> flying around the globe -- hope to dig in soon.

So that nba.com bug doesn't reproduce anymore and Chrome has the same experience for dial.uber.com. I think we should close this as INVALID (and I'll tweet at Uber to give them a heads up -- or report a bug if I can find the right place to do so).
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
I can only find places to report bug bounty bugs, so I tweeted at @Uber_Support: https://twitter.com/miketaylr/status/797218946302746624
(they replied with the right address to file an issue, so i did)
You need to log in before you can comment on or make changes to this bug.