Crash in java.lang.IndexOutOfBoundsException: at java.util.LinkedList.get(LinkedList.java)

RESOLVED DUPLICATE of bug 775512

Status

()

Firefox for Android
Awesomescreen
--
critical
RESOLVED DUPLICATE of bug 775512
2 years ago
2 years ago

People

(Reporter: gcp, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-a272d692-40f0-4e6e-b366-7ac962160817.
=============================================================

Open awesomebar. Go to history, synced devices. Pull down to refresh.
This is the #2 Fennec topcrash in Nightly, with 33 occurrences in the past week.

This is the #3 Fennec topcrash in Aurora, with 28 occurrences in the past week.

It's a Java exception:

> java.lang.IndexOutOfBoundsException
>	at java.util.LinkedList.get(LinkedList.java:519)
>	at org.mozilla.gecko.home.ClientsAdapter.getItemTypeForPosition(ClientsAdapter.java:135)
>	at org.mozilla.gecko.home.ClientsAdapter.getItemViewType(ClientsAdapter.java:147)
>	at org.mozilla.gecko.widget.HistoryDividerItemDecoration.getItemOffsets(HistoryDividerItemDecoration.java:28)
>	at android.support.v7.widget.RecyclerView.getItemDecorInsetsForChild(Unknown Source)
>	at android.support.v7.widget.RecyclerView$LayoutManager.measureChildWithMargins(Unknown Source)
>	at android.support.v7.widget.LinearLayoutManager.layoutChunk(Unknown Source)
>	at android.support.v7.widget.LinearLayoutManager.fill(Unknown Source)
>	at android.support.v7.widget.LinearLayoutManager.onLayoutChildren(Unknown Source)
>	at android.support.v7.widget.RecyclerView.dispatchLayout(Unknown Source)
>	at android.support.v7.widget.RecyclerView.onLayout(Unknown Source)

liuche, do you know about this code? Can you please take a look?
Flags: needinfo?(liuche)

Comment 2

2 years ago
Seems to be fixed in bug 775512!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 775512

Updated

2 years ago
Flags: needinfo?(liuche)
You need to log in before you can comment on or make changes to this bug.