Closed Bug 12961 Opened 20 years ago Closed 20 years ago

incr. reflow of table causes paint problem

Categories

(Core Graveyard :: GFX, defect, P3, major)

x86
Windows NT

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: buster, Assigned: beard)

References

()

Details

(Whiteboard: Fixed with nsViewManager2)

open test case in viewer
turn on edit mode
shrink your window so a vertical scrollbar appears
scroll to the bottom
delete the last character 'z'
the table displays poorly.
any refresh makes the table display correctly
I don't see a test case here.

Does the problem happen when there's no scrollbar, or if you're not scrolled at
the very bottom?

If the answer to either of those two questions is NO, then this doesn't sound
like a layout problem it sounds like a view manager (compositor) problem...
to answer Troy's questions:
1) the problem only happens if there is a scrollbar.
2) with limited testing, I don't see it except at the bottom of the page.



adding test case:

<HTML>
<BODY>
a<br>
b<br>
c<br>
<TABLE border>
<TR>
  <TD>1</TD>
  <TD>2</TD>
</TR>
<TR>
  <TD>3</TD>
  <TD>4</TD>
</TR>
</TABLE>
z
</BODY>
</HTML>
Assignee: troy → beard
Component: Layout → Compositor
Therefore it's not a layout bug...
Status: NEW → ASSIGNED
Target Milestone: M12
Target Milestone: M12 → M13
Viewer isn't working well enough to test this on the Mac, so this is impossible
for me to reproduce. Is it still happening in latest builds, and can you get
anything like this to happen in mozilla? Otherwise, I'd be tempted to mark
WONTFIX.
If this is a viewer only bug, I'm inclined to not fix it. Can you confirm?
Target Milestone: M13 → M14
when I submitted the bug, it certainly was not specific to viewer.  Thinking it
was a layout bug, I wrote it up using viewer because we always get more traction
out of the layout team when they don't have to run mozilla.  I originally found
this just running the mozilla editor app.  Have not confirmed that it still
occurs.
This looks good to me in current 6-Feb-2000 build, using nsViewManager2.
Whiteboard: Fixed with nsViewManager2
nsViewManager2 landed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed in the Feb 21 build.
Status: RESOLVED → VERIFIED
Blocks: 136189
No longer blocks: 136189
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.