Closed Bug 1296113 Opened 3 years ago Closed 3 years ago

accessible element insertion following inaccessible element insertions results in a wrong tree

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: surkov, Assigned: surkov)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
No description provided.
Attachment #8782182 - Flags: review?(yzenevich)
Assignee: nobody → surkov.alexander
Comment on attachment 8782182 [details] [diff] [review]
patch

Review of attachment 8782182 [details] [diff] [review]:
-----------------------------------------------------------------

looks good, just one nit

::: accessible/tests/mochitest/treeupdate/test_general.html
@@ +99,5 @@
> +        var accTree =
> +          { SECTION: [ // container
> +            { PUSHBUTTON: [
> +              { TEXT_LEAF: [] }
> +            ] }, 

nit: trailing space
Attachment #8782182 - Flags: review?(yzenevich) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/32b100ffa607020d78092a1c0c50b574cc5cec0d
Bug 1296113 - accessible element insertion following inaccessible element insertions results in a wrong tree, r=yzen
https://hg.mozilla.org/mozilla-central/rev/32b100ffa607
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.