Closed Bug 1296160 Opened 4 years ago Closed 3 years ago

Measure the cost of IPC (sync) for gdoc test cases.

Categories

(Core :: IPC, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1333489
Tracking Status
firefox51 --- affected

People

(Reporter: sinker, Unassigned)

References

(Blocks 1 open bug)

Details

We start a project to study google document's performance issues at bug 1260981 and it's blockers.  One thing we found the JS code of gdoc may use a lot of APIs that introduce sync IPC messages.

This bug here is to study/measure the cost of IPC for the JS of gdoc, and make decisions of solutions once we have a better knowledge.
I have found following sync IPC message are sent by content process while loading a document.
 - PContent::Msg_ClipboardHasType (1xms)
 - PBrowser::Msg_NotifyIMEFocus
 - PCookieService::Msg_GetCookieString (0~11ms)
 - PContent::Msg_RpcMessage
 - PRemoteSpellcheckEngine::Msg_SetDictionary (70ms)

Time for these sync IPC messages are vary on the load of system.
I have filed bug 1331674 about the general perf issues with sync IPC.  Some of the messages in comment 1 are already filed as blockers for this, please feel free to file new blockers against that.
See Also: → SyncIPC
Re-open if this is not a duplicate of the probe that landed.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333489
You need to log in before you can comment on or make changes to this bug.