[PP]Not able to read migrated bookmarks, not able to add bookmarks

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: agracebush, Assigned: mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Steps to reproduce:
1. Do a clean install of seamonkey (clean mozregistry.dat)
2. Run apprunner -install
3. Migrate a 4.x profile

Expected results: Migrated profile bookmarks available for use in seamonkey
Actual results: bookmark menu has only two options add current page and manage
bookmarks
Second launch of seamonkey does show migrated bookmarks
Migrated bookmarks file is present in proper profile directory but not being
read until second launch
Launching with a second migrated profile shows same bookmarks
Not sure if this is related to bug 9943

Build: 1999090108 WinNT, testing others now
(Reporter)

Comment 1

19 years ago
Win98 tested ok with one profile to migrate--I could reproduce if I added a
second 4.x profile
This seems to happen on machines that have more than 1 profile to be migrated.

Updated

19 years ago
Assignee: don → dbragg
Component: Browser-General → Profile Migration

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Comment 2

19 years ago
This MAY be related to the Init being done on the prefs file.  As soon as I get
the "reset" code in, I'll mark this fixed.  If there's still a problem, it may
be a core bug.  Accepting.

Comment 3

19 years ago
*** Bug 13353 has been marked as a duplicate of this bug. ***

Updated

19 years ago
OS: Windows NT → All
Hardware: PC → All

Comment 4

19 years ago
Marking this XP as it occurs on all builds as of 1999090909.
One does not have to 'migrate' a 4.x profile per se. The bug is
evident on a clean install and creation of the default mozProfile.
After doing this you will note the absence of the hardcoded bookmarks
in the Bookmarks menu and on the personal toolbar (tinderbox, bonsai, etc.),
until you quit and restart the browser. (just as earlier described)

Updated

19 years ago
Assignee: dbragg → don
Status: ASSIGNED → NEW
Component: Profile Migration → Browser-General

Comment 5

19 years ago
Oh, that's very different.  If this happens on clean installs, (no previous
version of Communicator) then this is not a migration-related bug since my code
is never called.  I'm reassigning to Browser-General (i.e. Don).  But adding
myself to the CC list so that if more info comes up that relates to migration
I'll see it.

Updated

19 years ago
Assignee: don → rjc
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
This works for me on Win98 with a clean build (including deleting
mozregistry.dat) from today (10/1/99) with both one 4.x profile as well as two
4.x profiles.

Feel free to re-test with newer builds since the last part of this bug report
talks about a build from almost a month ago!
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
tested on builds this week 19991004 through 19991007-all platforms

Updated

17 years ago
Blocks: 136189

Updated

17 years ago
No longer blocks: 136189
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.