Compilation stops: Can't open Perl Script /opt/mozilla//config/build-list.pl

VERIFIED INVALID

Status

SeaMonkey
Build Config
--
blocker
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: Ing. Alfred Boucek, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Win 9x 4.90)
BuildID:    Mozilla 0.9.8

After 3 seconds compilation time anf one screen output it stops with: 
Can’t open Perl Script „/opt/mozilla//config/build-list.pl“ No such file 
or directory
Gmake[2]: *** [exort ] error 2
...


Reproducible: Always
Steps to Reproduce:
1.tcsh
2.setenv CVSROOT  :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot
3.cvs login
anonymous
cd mozilla
gmake –f client.mk checkout
(Checkout finish 8.Mar.2002 2:50)
./configure
gmake


Actual Results:  Can’t open Perl Script „/opt/mozilla//config/build-
list.pl“ No such file or directory
Gmake[2]: *** [exort ] error 2
...


Expected Results:  complied version

I used SuSE Linux 7.2 and follow the instructions 
http://www.mozilla.org/build/unix.html
http://www.mozilla.org/build/unix-details.html

Maybe I am too stupit or their is a problem please help me
I intented to add functionality to the browser but I failed just compling the 
latest version I can get.
Thank you for your hint.
Alfred Boucek
Ing.AlfredBoucek@gmx.at
Can you provide a complete configure & build log? 
(Reporter)

Comment 2

17 years ago
See my screen shot...

linux:/usr/da/mozilla # ./configure
loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking for c++... (cached) c++
checking whether the C++ compiler (c++  ) works... yes
checking whether the C++ compiler (c++  ) is a cross-compiler... no
checking whether we are using GNU C++... (cached) yes
checking whether c++ accepts -g... (cached) yes
checking for ranlib... (cached) ranlib
checking for as... (cached) /usr/bin/as
checking for ar... (cached) /usr/bin/ar
checking for ld... (cached) /usr/bin/ld
checking for strip... (cached) /usr/bin/strip
checking for dlltool... no
checking whether gcc and cc understand -c and -o together... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking how to run the C++ preprocessor... (cached) c++ -E
checking for a BSD compatible install... (cached) /usr/bin/install -c
checking whether ln -s works... (cached) yes
checking for gawk... (cached) gawk
checking for xemacs... (cached) /usr/X11R6/bin/xemacs
checking for perl5... (cached) /usr/bin/perl
checking for minimum required perl version >= 5.004... 5.006
checking for full perl installation... yes
checking for whoami... (cached) /usr/bin/whoami
checking for autoconf... (cached) /usr/bin/autoconf
checking for unzip... (cached) /usr/bin/unzip
checking for zip... (cached) /usr/bin/zip
checking for makedepend... (cached) /usr/X11R6/bin/makedepend
checking for xargs... (cached) /usr/bin/xargs
checking for doxygen... (cached) /usr/bin/doxygen
checking for gmake... (cached) /usr/bin/gmake
checking whether /usr/bin/gmake sets ${MAKE}... (cached) yes
checking for X... (cached) libraries /usr/X11R6/lib, headers /usr/X11R6/include 
checking for dnet_ntoa in -ldnet... (cached) no
checking for dnet_ntoa in -ldnet_stub... (cached) no
checking for gethostbyname... (cached) yes
checking for connect... (cached) yes
checking for remove... (cached) yes
checking for shmat... (cached) yes
checking for IceConnectionNumber in -lICE... (cached) yes
checking whether ld has archive extraction flags... (cached) yes
checking for ANSI C header files... (cached) yes
checking for working const... (cached) yes
checking for mode_t... (cached) yes
checking for off_t... (cached) yes
checking for pid_t... (cached) yes
checking for size_t... (cached) yes
checking for uid_t in sys/types.h... (cached) yes
checking for st_blksize in struct stat... (cached) yes
checking for int16_t... (cached) yes
checking for int32_t... (cached) yes
checking for int64_t... (cached) yes
checking for int64... (cached) no
checking for uint... (cached) yes
checking for uint_t... (cached) no
checking for uint16_t... (cached) no
checking for uname.domainname... (cached) no
checking for uname.__domainname... (cached) yes
checking for 64-bit OS... no
checking for usable wchar_t (2 bytes, unsigned)... (cached) no
checking for compiler -fshort-wchar option... (cached) no
checking for dirent.h that defines DIR... (cached) yes
checking for opendir in -ldir... (cached) no
checking for sys/byteorder.h... (cached) no
checking for compat.h... (cached) no
checking for getopt.h... (cached) yes
checking for sys/bittypes.h... (cached) no
checking for memory.h... (cached) yes
checking for unistd.h... (cached) yes
checking for gnu/libc-version.h... (cached) yes
checking for nl_types.h... (cached) yes
checking for X11/XKBlib.h... (cached) yes
checking for sys/statvfs.h... (cached) yes
checking for sys/statfs.h... (cached) yes
checking for sys/vfs.h... (cached) yes
checking for sys/mount.h... (cached) yes
checking for sys/cdefs.h... (cached) yes
checking for gethostbyname_r in -lc_r... (cached) no
checking for atan in -lm... (cached) yes
checking for dlopen in -ldl... (cached) yes
checking for socket in -lsocket... (cached) n
checking for XDrawLines in -lX11... (cached) yes
checking for XextAddDisplay in -lXext... (cached) yes
checking for IceFlush in -lICE... (cached) yes
checking for SmcCloseConnection in -lSM... (cached) yes
checking for XtFree in -lXt... (cached) yes
checking for XineramaIsActive in -lXinerama... (cached) yes
checking for X11/extensions/Xinerama.h... (cached) yes
checking for XShmCreateImage in -lXext... (cached) yes
checking for X11/extensions/XShm.h... (cached) yes
checking for XieFloGeometry in -lXIE... (cached) yes
checking for X11/extensions/XIElib.h... (cached) yes
checking for pthread_create in -lpthreads... no
checking for pthread_create in -lpthread... yes
checking whether gcc accepts -pthread... yes
checking whether mmap() sees write()s... yes
checking whether gcc needs -traditional... (cached) no
checking for 8-bit clean memcmp... (cached) yes
checking for random... (cached) yes
checking for strerror... (cached) yes
checking for lchown... (cached) yes
checking for fchmod... (cached) yes
checking for snprintf... (cached) yes
checking for localtime_r... (cached) yes
checking for statvfs... (cached) yes
checking for memmove... (cached) yes
checking for rint... (cached) yes
checking for nl_langinfo... (cached) yes
checking for strtok_r... (cached) yes
checking for flockfile... (cached) yes
checking for gnu_get_libc_version()... (cached) yes
checking whether va_list assignments need array notation... (cached) no
checking for C++ exceptions flag... (cached) -fno-exceptions
checking for gcc 3.0 ABI... (cached) no
checking for ios::binary... (cached) yes
checking for ios::bin... (cached) yes
checking for C++ "explicit" keyword... (cached) yes
checking for C++ template specialization support... (cached) yes
checking for modern C++ template specialization syntax support... (cached) yes
checking whether partial template specialization works... (cached) yes
checking whether operators must be re-defined for templates derived from 
templates... (cached) no
checking whether we need to cast a derived template to pass as its base 
class... (cached) no
checking whether the compiler can resolve const ambiguities for templates... 
(cached) yes
checking whether the C++ "using" keyword can change access... (cached) no
checking whether the C++ "using" keyword resolves ambiguity... (cached) no
checking for "std::" namespace... (cached) yes
checking whether standard template operator!=() is ambiguous... (cached) 
unambiguous
checking for C++ reinterpret_cast... (cached) yes
checking for C++ dynamic_cast to void*... (cached) yes
checking whether C++ requires implementation of unused virtual methods... 
(cached) yes
checking for trouble comparing to zero near std::operator!=()... (cached) no
checking for LC_MESSAGES... (cached) yes
checking for nspr-config... no
checking for NSPR - version >= 4.0.0 (skipping)... no
checking for jpeg_destroy_compress in -ljpeg... (cached) yes
checking for zlib.h... yes
checking for gzread in -lz... (cached) yes
checking for png_get_valid in -lpng... (cached) yes
checking for mng_initialize in -lmng... (cached) yes
checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.2.0... yes
checking for freetype-config... (cached) /usr/bin/freetype-config
checking for FreeType - version >= 6.1.0... no
*** The FreeType test program failed to run.  If your system uses
*** shared libraries and they are installed outside the normal
*** system library path, make sure the variable LD_LIBRARY_PATH
*** (or whatever is appropiate for your system) is correctly set.
checking for freetype-config... (cached) /usr/bin/freetype-config
checking for FreeType - version >= 8.0.2... no
checking for XpGetPrinterList in -lXp... (cached) yes
checking for cplus_demangle in -liberty... (cached) yes
checking for gcc -pipe support... yes
checking whether C++ compiler has -pedantic long long bug... no
checking for correct overload resolution with const and templates... no
checking whether compiler supports -Wno-long-long... yes
checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.0... yes
check
ing for libIDL-config... /usr/bin/libIDL-config
checking for libIDL - version >= 0.6.3... yes
creating ./config.status
creating build/unix/mozilla-config
creating config/autoconf.mk
configuring in nsprpub
running /bin/sh ./configure  --with-dist-prefix=/usr/da/mozilla/dist --with-
mozilla --cache-file=.././config.cache --srcdir=.
loading cache .././config.cache
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking for whoami... (cached) /usr/bin/whoami
checking for c++... (cached) c++
checking whether the C++ compiler (c++  ) works... yes
checking whether the C++ compiler (c++  ) is a cross-compiler... no
checking whether we are using GNU C++... (cached) yes
checking whether c++ accepts -g... (cached) yes
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for ranlib... (cached) ranlib
checking for as... (cached) /usr/bin/as
checking for ar... (cached) /usr/bin/ar
checking for ld... (cached) /usr/bin/ld
checking for strip... (cached) /usr/bin/strip
checking for dlltool... no
checking for windres... no
checking for gcc -pipe support... yes
checking for perl5... (cached) /usr/bin/perl
checking for dlopen... (cached) no
checking for dlopen in -ldl... (cached) yes
checking whether gcc needs -traditional... (cached) no
checking for lchown... (cached) yes
checking for strerror... (cached) yes
checking for pthread_create in -lpthreads... no
checking for pthread_create in -lpthread... yes
checking whether gcc accepts -pthread... yes
creating ./config.status
creating Makefile
creating config/Makefile
creating config/autoconf.mk
creating config/nsprincl.mk
creating config/nsprincl.sh
creating config/nspr-config
creating lib/Makefile
creating lib/ds/Makefile
creating lib/libc/Makefile
creating lib/libc/include/Makefile
creating lib/libc/src/Makefile
creating lib/tests/Makefile
creating pr/Makefile
creating pr/include/Makefile
creating pr/include/md/Makefile
creating pr/include/obsolete/Makefile
creating pr/include/private/Makefile
creating pr/src/Makefile
creating pr/src/io/Makefile
creating pr/src/linking/Makefile
creating pr/src/malloc/Makefile
creating pr/src/md/Makefile
creating pr/src/md/unix/Makefile
creating pr/src/memory/Makefile
creating pr/src/misc/Makefile
creating pr/src/threads/Makefile
creating pr/tests/Makefile
creating pr/tests/dll/Makefile
creating pr/src/pthreads/Makefile
configure: warning: Recreating autoconf.mk with updated nspr-config output
configuring in directory/c-sdk/ldap
running /bin/sh ./configure  --prefix=/usr/da/mozilla/dist --cache-
file=../../.././config.cache --srcdir=.
loading cache ../../.././config.cache
creating ./config.status
creating Makefile
creating build/Makefile
creating build/autoconf.mk
creating include/Makefile
creating libraries/Makefile
creating libraries/libldap/Makefile
creating libraries/liblber/Makefile
linux:/usr/da/mozilla # make
make tier_0
make[1]: Entering directory `/usr/da/mozilla'
tier_0: config build include
make[2]: Entering directory `/usr/da/mozilla/config'
/usr/bin/perl -I. ./bdate.pl build_number
../config/nsinstall -R -m 444 nsBuildID.h ../dist/include
/usr/bin/perl -I/opt/mozilla//config /opt/mozilla//config/build-
list.pl ../dist/include/.headerlist nsBuildID.h
Can't open perl script "/opt/mozilla//config/build-list.pl": No such file or 
directory
make[2]: *** [export] Error 2
make[2]: Leaving directory `/usr/da/mozilla/config'
make[1]: *** [tier_0] Error 2
make[1]: Leaving directory `/usr/da/mozilla'
make: *** [default] Error 2


Thank you very much for quick response. 
Alfred Boucek 9.March 2002

You are running the build from /usr/da/mozilla according to your shell prompt
(and the nspr configure args) but it's looking in /opt/mozilla for a build file.
Why? Do you have MOZILLA_DIR set in your env?
(Reporter)

Comment 4

17 years ago
I had to enter 
MOZILLA_DIR=/usr/da/mozilla
and i was able to complie und run mozilla. 

Thank you for the hit, I didN't find this by myself on the net.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
That's because MOZILLA_DIR is a variable used by the build system internally. 
It's not meant to be set in the environment when building. 
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
The proper resolution is invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID

Comment 7

17 years ago
verified invalid.
Status: RESOLVED → VERIFIED
Summary: Compilation stops: Can’t open Perl Script /opt/mozilla//config/build-list.pl → Compilation stops: Can't open Perl Script /opt/mozilla//config/build-list.pl
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.