Closed Bug 1296398 Opened 3 years ago Closed Last year
naming of system add-on variables should be consistent with "defaults" and "updates"
Right now the AddonManager code refers to system add-ons in the app location as "SYSTEM_DEFAULTS" and the profile location as "SYSTEM_ADDONS". It would be clearer to call these "SYSTEM_DEFAULTS" and "SYSTEM_UPDATES".
Right now we have this set: KEY_APP_SYSTEM_ADDONS KEY_APP_SYSTEM_DEFAULTS KEY_APP_SYSTEM_LOCAL KEY_APP_SYSTEM_SHARE KEY_APP_SYSTEM_USER Only the first two are what we call "system add-ons". So maybe it would be better to change the first two to: KEY_APP_SYSTEM_ADDONS_UPDATES KEY_APP_SYSTEM_ADDONS_DEFAULTS
Summary: making naming of system add-on variables consistent with "defaults" and "updates" → naming of system add-on variables should be consistent with "defaults" and "updates"
Per policy at https://wiki.mozilla.org/Bug_Triage/Projects/Bug_Handling/Bug_Husbandry#Inactive_Bugs. If this bug is not an enhancement request or a bug not present in a supported release of Firefox, then it may be reopened.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.