WebGL browser hangs while linking shader

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Aral Yaman, Unassigned)

Tracking

51 Branch
Unspecified
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8782629 [details]
linkerHang.html

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160818030226

Steps to reproduce:

open testcase linkerHang.html

hang or crash caused by array value in fragment shader
ivec4 crashme[32767];

no hang or crash with e.g 
ivec4 crashme[0];





Actual results:

Browser hangs (Maybe it is a crash)


Expected results:

No hang/crash
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 8.1
(Reporter)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.