e10s - Viewing Videos Makes Browser Lag

RESOLVED DUPLICATE of bug 1295214

Status

()

Core
Audio/Video: Playback
P1
normal
RESOLVED DUPLICATE of bug 1295214
a year ago
a year ago

People

(Reporter: Lily Rose, Assigned: jwwang)

Tracking

({nightly-community, regression, regressionwindow-wanted})

51 Branch
x86_64
Windows 10
nightly-community, regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
This is more prominent on Youtube videos, but I noticed my browser starting to lag a bit on Vimeo videos too (unless that was just a fluke). 

After a certain amount of time (10-ish minutes) while watching a video or having it running in an unfocused tab, the browser becomes quite sluggish and starts lagging and hanging in short bursts when doing actions.

Closing down the tab with the video, waiting for the video to finish, or simply pausing it stops the sluggishness however.

This problem started around a week or so ago, and there's even a reddit thread about it here: https://www.reddit.com/r/firefox/comments/4xjemm/future_of_multi_process_electrolysis/
(Reporter)

Updated

a year ago
Keywords: nightly-community
(In reply to Lily Rose from comment #0)
> This problem started around a week or so ago, and there's even a reddit
> thread about it here:
> https://www.reddit.com/r/firefox/comments/4xjemm/
> future_of_multi_process_electrolysis/

Any chance you could use mozregression ( http://mozilla.github.io/mozregression/ ) to find out exactly what broke it?
Component: General → Audio/Video: Playback
Flags: needinfo?(thesweetlilycake)
Keywords: regression, regressionwindow-wanted
Product: Firefox → Core
tracking-e10s: --- → ?
Can you paste in about:support into a comment here?
Priority: -- → P1
(Reporter)

Comment 3

a year ago
Sorry for the radio silence! Past few days I've been preparing for school, and had my first school day after the summer break again just yesterday, but I will try to find a regression window later today/tomorrow!

about:support :

Application Basics
------------------

Name: Firefox
Version: 51.0a1
Build ID: 20160822064441
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
OS: Windows_NT 10.0
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-314b1878-3d84-4e64-97bf-bd90b2160822
Submitted: 19 minutes ago

Report ID: bp-acc1bb72-412c-44d3-95e5-2511e2160822
Submitted: 19 minutes ago

Report ID: bp-e4576832-4b61-426b-9868-e0eb72160822
Submitted: 19 minutes ago

Report ID: bp-ff9ff637-7c47-45a4-b467-4a3ad2160822
Submitted: 19 minutes ago

Report ID: bp-67958504-02a9-412c-81bf-414622160822
Submitted: 20 minutes ago

Report ID: bp-7dafbdbe-dda6-4064-bc0a-d45592160822
Submitted: 20 minutes ago

Report ID: bp-2dd74afe-7825-435f-96a1-2eaa52160822
Submitted: 20 minutes ago

Report ID: bp-1f744f62-4389-40df-a3dc-7e0092160822
Submitted: 17 hours ago

Report ID: bp-e4254743-cfd7-4c59-8a1a-f5d932160822
Submitted: 17 hours ago

Report ID: bp-6bf8fe1c-6d94-4ea7-816d-ca7972160822
Submitted: 17 hours ago

Report ID: bp-fb367869-f8b3-41d5-bddf-670e32160822
Submitted: 17 hours ago

Report ID: bp-18bdc21f-e9d5-4212-8095-dbf232160822
Submitted: 17 hours ago

Report ID: bp-2b54fb54-3404-4139-ae29-3851c2160822
Submitted: 17 hours ago

Report ID: bp-e057e2a8-3789-4ace-a3af-588492160822
Submitted: 17 hours ago

Report ID: bp-9a84ff25-e291-476d-904e-f3cf42160822
Submitted: 17 hours ago

Report ID: bp-1e1f529c-5477-41a1-9687-2b00b2160822
Submitted: 17 hours ago

Report ID: bp-e1ba8a1c-b68c-425a-830a-194102160822
Submitted: 17 hours ago

Report ID: bp-d7eea087-361f-4d01-ba9c-bf6012160822
Submitted: 17 hours ago

Report ID: bp-dfe6ed81-e74b-411c-9aaf-086e72160822
Submitted: 17 hours ago

Report ID: bp-4f5f517f-ccde-4ab9-b7aa-adaab2160822
Submitted: 17 hours ago

Report ID: bp-ed35c234-c151-4935-bf2d-bac9a2160822
Submitted: 17 hours ago

Report ID: bp-0ce0c2dd-859d-430a-8bfe-f55112160822
Submitted: 17 hours ago

Report ID: bp-3a1ae432-d5dc-4864-b66a-a73fa2160822
Submitted: 17 hours ago

Report ID: bp-4975b436-adce-4c73-8623-34c542160822
Submitted: 17 hours ago

Report ID: bp-d17f2b27-7b0e-40a6-a438-8b12f2160822
Submitted: 17 hours ago

Report ID: bp-f886acb3-2447-4ba3-a4ac-fb5f22160822
Submitted: 17 hours ago

Report ID: bp-76d941a7-e06a-4bcd-ba95-4b89c2160820
Submitted: 2 days ago

Report ID: bp-0e716834-ac9a-459b-bb9a-07c9b2160820
Submitted: 2 days ago

Report ID: bp-2f37c3e4-366f-4818-a5eb-c9ee02160820
Submitted: 2 days ago

Report ID: bp-d1a20bb3-29d5-44fb-8e8b-f300b2160820
Submitted: 2 days ago

Report ID: bp-0385bf1a-ea16-4f86-92b0-6a2e82160820
Submitted: 2 days ago

Report ID: bp-369a0e41-defc-4afa-b59f-ab24a2160820
Submitted: 2 days ago

Report ID: bp-de5da1d7-6ac3-4229-99a7-9c94f2160820
Submitted: 2 days ago

Report ID: bp-045b9efb-be21-4c6d-b595-c49a92160820
Submitted: 2 days ago

Report ID: bp-055a01cc-b91f-4c52-bbcf-40ce52160820
Submitted: 2 days ago

Report ID: bp-325fe600-8f9f-43fb-b5a7-2028a2160820
Submitted: 2 days ago

Report ID: bp-8ab520f3-9ed5-4600-9d84-80c4f2160820
Submitted: 2 days ago

Report ID: bp-7c2f72ef-c426-4f4c-aa88-6c4262160820
Submitted: 2 days ago

Report ID: bp-1bc4721b-cbdf-4663-b0e5-8a90e2160820
Submitted: 2 days ago

All Crash Reports (including 8 pending crashes in the given time range)

Extensions
----------

Name: FlyWeb
Version: 1.0.0
Enabled: true
ID: flyweb@mozilla.org

Name: Multi-process staged rollout
Version: 1.0
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon R9 200 / HD 7900 Series Direct3D11 vs_5_0 ps_5_0)
WebGL2 Renderer: ATI Technologies Inc. -- AMD Radeon R9 200 / HD 7900 Series
Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted
Audio Backend: wasapi
Direct2D: true
DirectWrite: true (10.0.10586.0)
GPU #1
Active: Yes
Description: AMD Radeon R9 200 / HD 7900 Series
Vendor ID: 0x1002
Device ID: 0x6798
Driver Version: 16.300.2511.1001
Driver Date: 8-11-2016
Drivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Subsys ID: 32111682
RAM: 3072

Diagnostics
ClearType Parameters: DISPLAY1 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 0 ] DISPLAY2 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 0 Enhanced Contrast: 0 ]
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
ClearType Parameters: DISPLAY1 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 0 ] DISPLAY2 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 0 Enhanced Contrast: 0 ]





Important Modified Preferences
------------------------------

browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.privatebrowsing.autostart: true
browser.sessionstore.upgradeBackup.latestBuildID: 20160610073607
browser.startup.homepage_override.buildID: 20160822064441
browser.startup.homepage_override.mstone: 51.0a1
dom.apps.lastUpdate.buildID: 20160617030217
dom.apps.lastUpdate.mstone: 50.0a1
dom.apps.reset-permissions: true
dom.ipc.processCount: 999999
extensions.lastAppVersion: 51.0a1
media.benchmark.vp9.fps: 249
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86_64-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1460455846
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1471558418
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20160818030226
media.gmp-manager.lastCheck: 1471558418
media.gmp-widevinecdm.abi: x86_64-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1471558420
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: true
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.sanitizeOnShutdown: true
security.sandbox.content.tempDirSuffix: {b5a6e32a-d39a-405e-8ecd-6d26d885a268}
services.sync.declinedEngines:
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSSMIME
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSSSL
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

NSSUTIL
Expected minimum version: 3.27 Beta
Version in use: 3.27 Beta

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 2
(Reporter)

Comment 4

a year ago
Think I just spent 2-3 hours trying to find the regression but with no answer to give.. :/ 
Sometimes I think the build version works fine just to re-try the same test on the same build and see it still lagging the browser..

Would using the profiler maybe work for this issue? 

Could it potentially be something driver related perhaps? Not sure when, but I did recently update my graphics driver and it could be that I started seeing this issue around the same time, especially since I see it on older builds too where I cannot remember ever having this issue, or at least not to an extent where it made my browsing hard.

It's most noticeable when typing text, though. On start it's smooth, but after the bug starts happening typing text becomes a laggy event where I can type something and the text will come a second later, something you sometimes see on phones. 

On the other hand there was that reddit thread, so I am kind of lost now..
Flags: needinfo?(thesweetlilycake)
All of the crash reports Lily posted are [@ IPCError-browser | ShutDownKill ]

Updated

a year ago
Depends on: 1295214
Assignee: nobody → jwwang
(Reporter)

Comment 6

a year ago
Bug 1295214 seems to have fixed this issue for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1295214
tracking-e10s: ? → ---
No longer depends on: 1295214
You need to log in before you can comment on or make changes to this bug.