WebExtensions window.open not working from extension code

RESOLVED DUPLICATE of bug 1282021

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1282021
a year ago
a year ago

People

(Reporter: Gabe O'Leary, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

I am trying to use window.open() with certain settings to get around this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1296481
I call window.open() or window.open(someurl) from within my extension code.


Actual results:

Nothing occurs except for a return value of null.  This indicates a failure according to documentation.


Expected results:

In chrome when I call window.open, it opens a new window (tab) as expected and returns it.
(Reporter)

Updated

a year ago
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1282021
You need to log in before you can comment on or make changes to this bug.