Can't play H.264 video on Windows 10 N with Media Feature Pack after Anniversary Update

RESOLVED FIXED

Status

()

Core
Audio/Video: Playback
P1
major
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: karl anliot, Unassigned)

Tracking

48 Branch
Unspecified
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

Installed firefox 32 bit
(20160817112116
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0)
Installed     Media Feature Pack for N and KN versions of Windows 10 (both 64 and 32 bit) 

browsed this page: http://www.quirksmode.org/html5/tests/video.html



Actual results:

no h.264 in Firefox


Expected results:

passed the http://www.quirksmode.org/html5/tests/video.html video test for h.264
1. Go to about:support
2. Press "Copy text to clipboard"
3. Open Notepad
4. Paste the copied text in clipboard to it
5. Save it
6. Attach it here as  attachment
Flags: needinfo?(kanliot)
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Please read https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows and install https://www.microsoft.com/en-us/download/details.aspx?id=49919
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
missed that it was installed.
make sure you restart firefox after install media feature pack
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---

Comment 4

a year ago
According to https://www.reddit.com/r/firefox/comments/4wff3i/how_to_force_enable_webm_videos/?st=is2q7n0b&sh=4da96a11 the Windows 10 Anniversary Update breaks older versions of the Media Feature Pack. If your copy of Windows just received the Anniversary Update, then you will need to update your Media Feature Pack to a compatible version, which you can get here: https://www.microsoft.com/en-us/download/details.aspx?id=53356

On a side note, the article https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows should be updated to mention needing a different Media Feature Pack just for the Anniversary Update, as previous versions appear to be incompatible. Does Firefox have some way of notifying the user that their Media Feature Pack is out of date?
(In reply to Trevor Rowbotham from comment #4)
> On a side note, the article
> https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-
> windows should be updated to mention needing a different Media Feature Pack
> just for the Anniversary Update, as previous versions appear to be
> incompatible.

Please tell me you're volunteering... you just need to sign up and suggest a change.

> Does Firefox have some way of notifying the user that their
> Media Feature Pack is out of date?

Gerald - can you tweak Decoder Doctor to handle this case?
Flags: needinfo?(gsquelart)
Priority: -- → P1
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #5)
> (In reply to Trevor Rowbotham from comment #4)
> > Does Firefox have some way of notifying the user that their
> > Media Feature Pack is out of date?
> 
> Gerald - can you tweak Decoder Doctor to handle this case?

Anything's possible I guess, but in this case it will depend on whether:
- The old media pack is erased by the anniversary update (easy case, DecDoc should already handle that, but we should ensure the SUMO page has the correct information),
- Or the old media pack is still around but not used and/or incompatible (harder case, DecDoc would need to go look at file versions).

In any case, it will take me a little while to answer this more thoroughly, as I need to spin up a new VM with the original Win10N, Firefox, old media pack, and then install the anniversary update. I'll start that in the background and come back to you with my findings... (Keeping NI:me as a self-reminder.)
Severity: normal → major
Summary: can't play h.264 video on window 10 N. → Can't play H.264 video on Windows 10 N with Media Feature Pack
OS: Unspecified → Windows 10

Comment 7

a year ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #5)
> (In reply to Trevor Rowbotham from comment #4)
> Please tell me you're volunteering... you just need to sign up and suggest a
> change.

Sounds easy enough, I'll take care of it later today or tomorrow.
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #5)
> (In reply to Trevor Rowbotham from comment #4)
> > Does Firefox have some way of notifying the user that their
> > Media Feature Pack is out of date?
> 
> Gerald - can you tweak Decoder Doctor to handle this case?

Experimented with Win10N + old media feature pack (KB3099229/KB3010081) + Anniversary update:
From what I can see, the whole C:\Windows directory (including media pack) is renamed to Windows.old, and a fresh copy (without media pack) is installed in C:\Windows.

Now, Decoder Doctor in Firefox still does its job: It shows a notification drop-down pointing at SUMO, which itself was updated on Aug 7 to refer to the latest media pack that works with the Anniversary update (KB3133719), which worked for me.

Before trying the new media pack I tried installing the old one. That didn't seem to do anything, i.e., media playback still broken, but also Firefox still suggesting to install a media pack.

So I don't think we can do much more than what's already there in Decoder Doctor and SUMO.
Flags: needinfo?(gsquelart)
One note: Decoder Doctor only warns about missing WMF since 49 (now in Beta), so most users of the current 48 release won't get the notification.
(Reporter)

Comment 10

a year ago
Created attachment 8783833 [details]
someone requested about:config, this is text copy of about:config
(Reporter)

Comment 11

a year ago
>then you will need to update your Media Feature Pack to a compatible version, 
>which you can get here: https://www.microsoft.com/en-us/download/details.aspx?id=53356

 Trevor Rowbotham, you're linking to a reddit thread where someone got h.264 to work.  for some reason his "steps" don't work for me.

I'm not implying that I understand the universe of Windows 10 service packs, but, it's not working.
(Reporter)

Comment 12

a year ago
I've fixed it on my PC.    Above comments listed https://www.microsoft.com/en-us/download/details.aspx?id=53356 as the solution.  That didn't work.

The correct link is https://www.microsoft.com/en-us/download/details.aspx?id=49919  which is a older update package for windows 10 (nearly a year) , and it now works.

I also noticed that HTML5 video was broken (and now fixed ) in MS edge as well.  No idea if you need to install both packs, as I probably can't remove the earlier pack anyhow.
Blocks: 848994
Status: REOPENED → NEW
Flags: needinfo?(kanliot)
Summary: Can't play H.264 video on Windows 10 N with Media Feature Pack → Can't play H.264 video on Windows 10 N with Media Feature Pack after Anniversary Update

Comment 13

a year ago
(In reply to karl anliot from comment #12)
> I've fixed it on my PC.    Above comments listed
> https://www.microsoft.com/en-us/download/details.aspx?id=53356 as the
> solution.  That didn't work.
> 
> The correct link is
> https://www.microsoft.com/en-us/download/details.aspx?id=49919  which is a
> older update package for windows 10 (nearly a year) , and it now works.
> 
> I also noticed that HTML5 video was broken (and now fixed ) in MS edge as
> well.  No idea if you need to install both packs, as I probably can't remove
> the earlier pack anyhow.

I'm glad you found a fix. You only need to have 1 installed.
(Reporter)

Comment 14

a year ago
Trevor you are speaking counterfactually.  I tested with one installed.

Comment 15

a year ago
The SUMO article has been updated now to include the older Media Feature Pack (KB3099229) for Windows 10 build 1151 as well as the new Media Feature Pack (KB3133719) required for anyone who has installed the Windows 10 build 1607 (Anniversary Update).
(In reply to Trevor Rowbotham from comment #15)
> The SUMO article has been updated now to include the older Media Feature
> Pack (KB3099229) for Windows 10 build 1151 as well as the new Media Feature
> Pack (KB3133719) required for anyone who has installed the Windows 10 build
> 1607 (Anniversary Update).

Thanks \o/
Status: NEW → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
> * Windows 10 Build 1607 (Anniversary Update): N and KN versions (Microsoft Support article KB3133719)
> * Windows 10 Build 1151: N and KN versions (Microsoft Support article KB3099229) 

"1607" and "1151" are versions rather than builds. Builds are "14393" and "10586", respectively.
Also, version 1507 (build 10240) is present. The media feature pack for build 10240 is described in KB3010081.

Comment 18

a year ago
(In reply to Masatoshi Kimura [:emk] from comment #17)
> > * Windows 10 Build 1607 (Anniversary Update): N and KN versions (Microsoft Support article KB3133719)
> > * Windows 10 Build 1151: N and KN versions (Microsoft Support article KB3099229) 
> 
> "1607" and "1151" are versions rather than builds. Builds are "14393" and
> "10586", respectively.
> Also, version 1507 (build 10240) is present. The media feature pack for
> build 10240 is described in KB3010081.

Thanks for the clarification.  I will update the article accordingly.
You need to log in before you can comment on or make changes to this bug.