Some methods in editor look for a editable node, but it's not explained by the method name. So, we should rename them as: * HTMLEditor::GetNextHTMLNode() -> HTMLEditor::GetNextEditableNode() * HTMLEditor::GetPriorHTMLNode() -> HTMLEditor::GetPrevEditableNode() * HTMLEditor::GetNextHTMLSibling() -> HTMLEditor::GetNextEditableSibling() * HTMLEditor::GetPriorHTMLSibling() -> HTMLEditor::GetPrevEditableSibling() (I like "Prev" better than "Prior" because a lot of code use it as opposite word of "Next" and it's same length as "Next".)
The first two also only return leaf nodes, which is practically speaking an even more critical detail, so I suggest GetPrev/NextEditableLeafNode() for the first two. Otherwise agreed.
Thanks you. I'll suggest to use this bug in Hacker event of Mozilla Japan at this weekend.