If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[kab] Firefox initial web parts for Kabyle

RESOLVED FIXED

Status

www.mozilla.org
L10N
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: flod, Assigned: Belkacem Mohammed)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

To release Firefox in Kabyle, we need a way to promote it. We do that via https://www.mozilla.org/firefox/ web pages. There's a set of pages that are essential to having a successful Firefox localization and promotion, and those depend on the files listed below. 

flod or Pascal will follow up here when the initial setup work is done. After that, you'll find the files to localize in GitHub.

The repositories you want to work with are located at https://github.com/mozilla-l10n/www.mozilla.org/tree/master/kab/ and https://github.com/mozilla-l10n/fhr-l10n/tree/master/kab/ . Files that need to be translated are, namely:

in https://github.com/mozilla-l10n/www.mozilla.org/tree/master/kab/

 download_button.lang
 firefox/channel.lang
 firefox/new.lang
 firefox/installer-help.lang
 firefox/sync.lang
 main.lang
 mozorg/home/index.lang
 mozorg/plugincheck.lang
 newsletter.lang

in https://github.com/mozilla-l10n/fhr-l10n/tree/master/kab/
 fhr.lang

There will also be some less important files available for you to translate, but please focus on the ones listed here first.

The status of web parts for your locale on GitHub can be checked at this URL (updated every 15 minutes)
http://l10n.mozilla-community.org/webdashboard/?locale=kab

All the translations you do will be available on the testing website, http://www-dev.allizom.org/kab/ , around 15-30 minutes after commit.

The Kabyle team will be driving this bug to completion.
Corrections: ignore newsletter.lang, the point of reference for mozilla.org is Peiying.
Locale: kab / Kabyle
(Assignee)

Comment 2

a year ago
Hi,

We don't know how can we be involved. We are trying the kab urls. They are not working.

We tried to take a look to french files to see if there is more strings to translate. Strings seems to be those are used to be translated  inMozilla.org project.

We are now translating Mozilla.org.

M.Belkacem
This bug depends on bug 1296550. Until that's fixed, those URLs won't be available. As suggested, please hold on translating files, because they might not be necessary.
(Assignee)

Comment 4

a year ago
Hi,

The translation is done on Pootle. I guess they will be be synchronized into Github?
You're right. I assumed the sync already happened given Peiying's comment, but it didn't.

All files are indeed localized, I think you won the award as fastest locale ever! Please let us know when you've been able to test most of the website.
(Assignee)

Comment 6

a year ago
Hi Francesco,

The translation, corrections is going on almost everyday after work for 2 or 3 hours  sometimes more.
Now I am taking a look to the dev website  (http://www-dev.allizom.org/kab/ )to see the render.

The team has already translated a lot of strings offline. We used to share files between members. We are just reviewing them. I am used to put them online.
(Assignee)

Comment 7

a year ago
I tested today all translated pages and corrected some errors. I will re-test tomorrow after next Sync as I got some wrong strings.

Kabyle community is happy today !!!
Thanks
Just run another import, dev server should be updated within 10 minutes.
(Assignee)

Comment 9

a year ago
Hi,

Some links are not redirected well to the good locale. For example, from the Home page to the page (https://www-dev.allizom.org/kab/firefox/new/), I am redirected to the fr locale ((https://www-dev.allizom.org/kab/firefox/new/).

I tested it on Firefox 48 (french locale) and Developer Edition (Kabyle locale) on Windows 7 french.
Can you explain exactly the steps to reproduce? If I go to https://www-dev.allizom.org/kab/ and click "Sider Firefox", I get Italian because that's the first language in my accept_languages header.

Can you go in about:config and check the value of the key intl.accept_languages? 

I've also updated this key in Pootle to 'kab-dz,kab,fr-FR,fr,en-US,en' (it was 'kab, kab-dz, en')
https://mozilla.locamotion.org/kab/firefox/translate/toolkit/chrome/global/intl.properties.po#unit=4270921

The idea is that you go from precise to broader locale codes, if French is a good fallback for Kabyle users, it should be there before English.
Side note: if instead you mean that you're asked to download the French build, that's expected. We're still waiting for repositories to be set-up.
(Assignee)

Comment 12

a year ago
I retested. All links are working fine.
(Assignee)

Comment 13

a year ago
Hi,

All files listed on this bug are now translated and reviewed. Please, should we go ahead with the translation of mozilla.org or we must wait for guidance?
The dashboard is empty, which means you translated all the files. I'll keep the bug open while we wait to enable the locale on production, but I want to wait to have builds before doing that.
(Assignee)

Comment 15

a year ago
Ok thanks Francesco,

Comment 16

a year ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/0c078d0efeb775eb4078314dab8237c02d5b80c9
Bug 1296551 - Enable Kabyle (kab) in production

https://github.com/mozilla/bedrock/commit/c76308eba74e90d8933c7d6338f56543263aa99b
Merge pull request #4329 from flodolo/bug1296551

Bug 1296551 - Enable Kabyle (kab) in production
I think we can close this one. Pages will be available in the next code push (I guess within the week).
Assignee: nobody → belkacem77
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.