The Activity Stream "Share" button is not available to add/remove services unless the page is share-able

RESOLVED WONTFIX

Status

()

Firefox
Activity Streams: General
RESOLVED WONTFIX
a year ago
7 months ago

People

(Reporter: cmuresan, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

Attachments

(1 attachment)

Created attachment 8782863 [details]
The share button is not available to add or remove services unless the page is share-able.mp4

[Affected versions]:
- Firefox 45.0 and up
- Activity Stream 1.1.2-dev

[Affected Platforms]:
- All Windows
- All Mac OS X
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on version (1.1.2-dev) was previously installed on a clean profile.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites. 
2. Open a new tab.
3. Observe the "Share" button. 

[Expected result]:
- The "Share" button is enabled and you should at least have the option to add/remove services.

[Actual result]:
- The "Share" button is disabled.

[Notes]:
- If you want to add/remove services you have to navigate to a share-able page where the button is enabled.
- Attached a screenshot of the issue.
Filed in GitHub as https://github.com/mozilla/activity-stream/issues/1130
Deprioritizing since share is not included in MVP
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.