environment/addons/activePlugins is not always an array

RESOLVED DUPLICATE of bug 1323964

Status

()

Toolkit
Telemetry
P3
normal
RESOLVED DUPLICATE of bug 1323964
2 years ago
2 years ago

People

(Reporter: rvitillo, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [measurement:client])

User Story

It appears that environment/addons/activePlugins is not always an array [1], which causes issues downstream.

[1] https://gist.github.com/vitillo/f1129de59ae649e23220583113493ea8
Comment hidden (empty)
Priority: -- → P3
Whiteboard: [measurement:client]
I suspect that this is bug 1323964.
Depends on: 1323964
As suggested by Georg in the previous comment, this is a dupe. In bug 1333806 comment 7, we ran an analysis to rule out an issue on the client.

(from bug 1333806 comment #7)
> I took some time to dig into the issue. It looks like empty arrays are shown
> as empty dictionaries upstream.
> 
> The notebook at [1] dissects the problem, showing that:
> 
> - Darwin has a ratio of 0.32, Linux 0.50 and Windows 0.26 (since the
> beginning of Jan 2017). This matches what we're seeing on re:dash (see the
> previous comments), roughly.
> - The problem isn't on the client, as I've looked up my pings: on the
> client, they show a list in activePlugins but on Spark it's a dict.
> 
> [1] - https://gist.github.com/Dexterp37/30b9ce2e127d0c90a36de93679540c4e
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1323964
You need to log in before you can comment on or make changes to this bug.