Android lint jobs mostly failing, after OSError: [Errno 2] No such file or directory

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
a year ago
4 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
treeherder
Filed by: philringnalda [at] gmail.com

https://treeherder.mozilla.org/logviewer.html#?job_id=2216733&repo=autoland

https://queue.taskcluster.net/v1/task/C70sIk9kThCqu2kZzil1Gw/runs/0/artifacts/public%2Flogs%2Flive_backing.log

Comment 1

a year ago
41 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 40
* mozilla-aurora: 1

Platform breakdown:
* android-4-0-armv7-api15: 40
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1296713&startday=2016-08-15&endday=2016-08-21&tree=all
This is an actual lint error that needs to be fixed (I think that's what we did on Friday):
https://queue.taskcluster.net/v1/task/C70sIk9kThCqu2kZzil1Gw/runs/0/artifacts/public%2Flogs%2Flive_backing.log

This looks weird and I don't know what it is. If it is caused by the lint error above then this error is super misleading.
https://treeherder.mozilla.org/logviewer.html#?job_id=2216733&repo=autoland
Depends on: 1294763

Comment 3

a year ago
9 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* try: 1
* mozilla-central: 1

Platform breakdown:
* android-4-0-armv7-api15: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1296713&startday=2016-08-22&endday=2016-08-28&tree=all
The lint error can be found from treeherder, from the uploaded artifacts. In this case:

https://public-artifacts.taskcluster.net/C70sIk9kThCqu2kZzil1Gw/0/public/android/lint/lint-results-automationDebug.html

UnusedResources: mobile/android/base/resources/drawable/scrollbar.png
(In reply to Michael Comella (:mcomella) [not actively working on fennec: expect slow responses] from comment #4)
> The lint error can be found from treeherder, from the uploaded artifacts. In
> this case:

This is from the link Sebastian gave in comment 2.

I thought we had a bug open to improve the error messages but I can't find it.
I don't see any failures on mozilla-central on 8/26 [1] – please reopen if this is still an issue

[1]: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=f38d60b049f0180156ff254c5bf3fae79020e4a5
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME

Comment 7

4 months ago
1 failures in 720 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* osx-cross: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1296713&startday=2017-07-10&endday=2017-07-16&tree=all
You need to log in before you can comment on or make changes to this bug.