Support for push notifications in Facebook

RESOLVED FIXED

Status

P1
normal
Rank:
100
RESOLVED FIXED
2 years ago
8 months ago

People

(Reporter: rick3162, Assigned: karlcow)

Tracking

Firefox 48

Firefox Tracking Flags

(platform-rel +)

Details

(Whiteboard: [platform-rel-Facebook], URL)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Using FF 48 x64 (and Nightly 51 x64) in win 10 x64.

Firefox supports push notifications since v44.

I've noticed some months now that Facebook offers push notifications in Chrome browser only.
If you login to Facebook in Chrome browser (only) -current stable version: 52-
then you're prompted to allow notifications
which in fact are push notifications (as shown via site's Settings|Notifications|"Desktop and Mobile").
Relevant help article: https://www.facebook.com/help/949954541709550

On the other hand, if you login in Firefox (even in latest Nightly 51)
the push notifications are not available in FB's Settings.


It would be great if Firefox would support push notifications in such a popular site as Facebook.

Comment 1

2 years ago
I'm assuming this is a FB issue, but it would be good to be sure. We ought to have contacts there that we can ping about this, I assume?
Component: General → Desktop
Flags: needinfo?(kdubost)
Product: Firefox → Tech Evangelism
Version: 48 Branch → Firefox 48
(Assignee)

Comment 2

2 years ago
Was it verified?

I will contact Facebook,
Flags: needinfo?(kdubost)
Whiteboard: [needsdiagnosis]
(Assignee)

Comment 3

2 years ago
oops too early. I will contact Facebook, … but it would be good to know the source of the issue. Where, How, etc.
(Assignee)

Comment 4

2 years ago
I sent an email to ask about it. 
But still would be great to have a bit more details about this.
Karl, I am aware that you've sent the mail and received some feedback. Do you mind following up with the current state?

I've done a quick check and can confirm that push notifications work fine if I spoof as Chrome, so this is not a platform issue but rather a intended feature to exclude Firefox. There is a lot of user agent checking going on in the sources, but I did not dive into it, given the feedback we've got in August. Would be great if you could follow up there to check if there is anything new.

I'm removing the needsdiagnosis label since we pretty much know this is intentional.
Flags: needinfo?(kdubost)
Whiteboard: [needsdiagnosis]
(Assignee)

Comment 6

2 years ago
Thanks for the reminder. I asked for status.
Initially the plan was that they would be releasing it on Sept 1st, 2016.
Assignee: nobody → kdubost
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(kdubost)
platform-rel: --- → ?
Whiteboard: [platform-rel-Facebook]
I'm the PM for Web Push and am working with Facebook directly on this issue.

(In reply to Dennis Schubert [:denschub] from comment #5)
> I've done a quick check and can confirm that push notifications work fine if
> I spoof as Chrome, so this is not a platform issue but rather a intended
> feature to exclude Firefox. There is a lot of user agent checking going on
> in the sources, but I did not dive into it, given the feedback we've got in
> August. Would be great if you could follow up there to check if there is
> anything new.

We've gone through a test roll out with Facebook already but due to problems with our permission prompts we aren't ready to roll out to all Firefox users.  This is a coordinated decision with Facebook.  We would have liked for the roll out to happen now but Firefox isn't ready yet.  We support Web Push from the platform side but our permission prompt is too easily ignored accidentally; causing lots of user frustration.  I can give regular updates to this bug but for now we'll be waiting on the new permissions prompt to land and then we can reset a new roll out date with Facebook.

> I'm removing the needsdiagnosis label since we pretty much know this is
> intentional.

Indeed.

Updated

2 years ago
platform-rel: ? → +

Updated

2 years ago
Rank: 100
Just following up.  The required changes to the Permissions UI have landed and are currently live in DevEdition right now.  We're on track for the Fx 53 release to contain these needed changes which will allow FB to turn on Push.
(In reply to Bryan Clark (DevTools PM) [:clarkbw] from comment #8)
> Just following up.  The required changes to the Permissions UI have landed
> and are currently live in DevEdition right now.  We're on track for the Fx
> 53 release to contain these needed changes which will allow FB to turn on
> Push.

Hey Bryan

Can you confirm that FB now supports push?
FB has been notified and this should roll out soon.  Will update when it does.

Comment 11

a year ago
¡Hola Bryan!

Did you get anything more precise than "soon"?

User on both SuMo and /r/firefox ask frequently about this.

¡Gracias!
Alex
Flags: needinfo?(clarkbw)
There is a staged roll out of push permissions happening right now and will continue into September.
Flags: needinfo?(clarkbw)
(Reporter)

Comment 13

a year ago
Bryan, September is over, Fx 56 stable has been released, 
but unfortunately push permissions have not been enabled.
Do you know when the roll out will be completed?
(Reporter)

Comment 14

11 months ago
Three months later, and push permissions still have not been enabled for me (I'm in Greece).

Any update on this?
(Reporter)

Comment 15

9 months ago
Push permissions are still not enabled (Fx 58 stable,)
Created attachment 8946706 [details]
Screenshot of Facebooks push notification settings

Hey Kostas,

that's... odd. Just for reference: when I visit [0] from my German IP, I see the attached view which allows me to turn the push notification on. I also tested this with the locale set to Greek, but that may or may not be a valid test case, since Facebook sometimes does IP-based locale settings.

Do you mind quickly confirming that you indeed to not see these options there? If they are still not visible for you, do you mind starting Firefox in Safe Mode [1] and check again, just to rule out any potential interference with any extension?

I'd check back with our contacts at Facebook if you'd still not see the options, even if running in Safe Mode.

[0]; https://www.facebook.com/settings?tab=notifications&section=push&view
[1]: https://support.mozilla.org/en-US/kb/Safe%2BMode

Thanks. :)
Flags: needinfo?(rick3162)
(Reporter)

Comment 17

9 months ago
> Do you mind quickly confirming that you indeed to not see these options there? If they are still not visible for you, do you mind starting Firefox in Safe Mode [1] and check again, just to rule out any potential interference with any extension?

Of course. 
So, I've tried visiting the URL in my everyday profile: no push notification options.
I also tried in Safe Mode: still no options.
I even tried in a fresh FF 58 profile: no options as well (see screenshot).


Thank you for offering to check with your contacts in Facebook.
Flags: needinfo?(rick3162)
(Reporter)

Comment 18

9 months ago
Created attachment 8946709 [details]
Screenshot of Facebooks push notification settings from a fresh FF 58 profile.jpg
(Reporter)

Comment 19

8 months ago
Created attachment 8956487 [details]
Facebook push notifications have eventually been enabled.jpg

Today Facebook push notifications have eventually been enabled for me (see screenshot). 
Using FF 58.0.2.
Great! Let's close as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 months ago
Priority: -- → P1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.